AnsweredAssumed Answered

Windows 2003 server returns DEP error for Eagleware servers

Question asked by vhlopez on Mar 14, 2009
The latest Eagleware license server (20007.03 SP1), will install OK, and run, until you have to restart the server. Upon reboot, the server returns this error message:

Data Execution Prevention – Microsoft Windows
To help protect your computer, Windows has closed this program.
Name: Eagle.exe

The error occurs only if you have a chip that allows for Windows to run a more secure memory control called DEP (Data Execution Prevention).

Microsoft's solution for Windows Server 2003 PCs is listed below, the links below will take you to the original Microsoft support document for Server 2003 PCs and for Windows XP and Tablet PCs:

Windows 2003 servers:
Windows XP and Tablets:

.....If you are logged on as an administrator, you can manually configure DEP to switch between the OptIn and OptOut policies by using the Data Execution Prevention tab in System Properties. The following procedure describes how to manually configure DEP on the computer:

  • Click Start, click Run, type sysdm.cpl, and then click OK

  • Click the Advanced tab, click Performance, and then click Settings

  • On the Data Execution Prevention tab, use one of the following procedures:


    • Click Turn on DEP for essential Windows programs and services only to select the OptIn policy
    • Click Turn on DEP for all programs and services except those I select to select the OptOut policy, and then click Add to add the programs that you do not want to use the DEP feature.

    • Click OK two times
    IT professionals can control system-wide DEP configuration by using a variety of methods. The Boot.ini file can be modified directly with scripting mechanisms or with the Bootcfg.exe tool that is included in Windows XP SP2.
    To configure DEP to switch to the AlwaysOn policy by using the Boot.ini file, follow these steps:

  • Click Start, right-click My Computer, and then click Properties

  • Click the Advanced tab, and then click Settings under the Startup and Recovery field

  • In the System startup field, click Edit. The Boot.ini file opens in Notepad

  • In Notepad, click Find on the Edit menu

  • In the Find what box, type /noexecute, and then click Find Next

  • In the Find dialog box, click Cancel

  • Replace policy_level with AlwaysOn. WARNING Make sure that you enter the text accurately. The Boot.ini file switch should now read: /noexecute=AlwaysOn

  • In Notepad, click Save on the File menu

  • Click OK two times

  • Restart the computer

  • Outcomes