AnsweredAssumed Answered

Troubleshooting network license installations

Question asked by ROB_LEFEBVRE on May 1, 2003
This post is referenced in the outgoing message sent by
Eagleware-Elanix Corporation when delivering new authorization codes for software.

The following troubleshooting and diagnostic steps will help to correct and/or identify issues with network installations.   Please go through the following:

Note: Windows 2003 server requires the HASP driver included with GENESYS 2003.10SP1 or later.  If you are installing an earlier version of GENESYS, please download the latest hasp driver from the support section of www.eagleware.com.

1) There must be a C:\\flexlm directory on the server.  If this directory does not exist, you should create it, otherwise you will get errors about multiple servers running.

2) Be sure you have entered the authorization codes on the SERVER.  We suggest reentering them or (with GENESYS 2003 or later) re-downloading them.

3) Be sure that the service is properly running on the server: *Stop* and *restart* "Eagleware License Manager" under services.

4) Check the licensing program log on the server: Under Start/Programs/GENESYS Server Maintenance, click View Licensing Program Log.  [NOTE: It can take about 15 seconds before the log is ready after the service is restarted.]  The log should look like this:

     15:36:13 (lmgrd) Logfile switched from
     15:36:24 (lmgrd) -----------------------------------------------
     15:36:24 (lmgrd)   Please Note:
     15:36:24 (lmgrd)
     15:36:24 (lmgrd)   This log is intended for debug purposes only.
     15:36:24 (lmgrd)   There are many details in licensing policies
     15:36:24 (lmgrd)   that are not reported in the information logged
     15:36:24 (lmgrd)   here, so if you use this log file for any kind
     15:36:24 (lmgrd)   of usage reporting you will generally produce
     15:36:24 (lmgrd)   incorrect results.
     15:36:24 (lmgrd)
     15:36:24 (lmgrd) -----------------------------------------------
     15:36:24 (lmgrd)
     15:36:24 (lmgrd)
     15:36:24 (lmgrd) FLEXlm (v6.1g) started on dell02 (IBM PC) (9/7/2001)
     15:36:24 (lmgrd) FLEXlm Copyright 1988-1999, Globetrotter Software, Inc.
     15:36:24 (lmgrd) US Patents 5,390,297 and 5,671,412.
     15:36:24 (lmgrd) World Wide Web:  http://www.globetrotter.com
     15:36:24 (lmgrd) License file(s): C:\\Program Files\\GENESYS Server\\LICENSE\\genesys.lic
     15:36:24 (lmgrd) lmgrd tcp-port 27000
     15:36:24 (lmgrd) Starting vendor daemons ...
     15:36:24 (lmgrd) Started eagle (internet tcp_port 0 pid 456)
     15:36:24 (eagle) Server started on <server> for:     genesys


The key points are: There should be no message saying "NO KEY FOUND" or any other error messages.  The end of the file should say "Server started on <server> for: genesys".  Troubleshooting steps include:

        a) Be sure that the key is attached.

        b) If the server is running Windows 2000 or later, you must be running version 8.0 or later of GENESYS.  Otherwise, you will get KEY NOT FOUND messgaes.

        c) Stop and restart the license service, as in step 2 above.  Check the log.  If the key is still not found, then install the latest HASP driver from www.hasp.com: In their site, go to Support&Downloads; HASP; HASP for End-Users; Latest HASP Device Driver; HDD32.zip.

        d) If the key is still not found, contact Eagleware or your distributor for further help.

5) Once the server is up, GENESYS must be installed on the client computer.  You must specify the name of the server to the client.  It is generally the same name found in the last line of the log file above.  At this point, GENESYS should run properly.  Troubleshooting:

        a) You should be able to PING the server using the name you entered.  Go to a MSDOS/command prompt and type "PING <server>".  You should see a list of round-trip times.  If you see time-out messages, then there is a problem with your network.

        b) There should be no firewalls between the end-computer and the server.

        c) On the client computer, under the main GENESYS directory, you'll find a file default.eg$.  Inside that file default.eg$ and toward the bottom, you'll find a LICENSEPATH statement.  Make sure th  

Outcomes