AnsweredAssumed Answered

Setup/cleanup runs twice when using Call (Bug?)

Question asked by OnlyOne on Sep 22, 2009
Latest reply on Sep 13, 2010 by OnlyOne
Hello,
i am using Windows XP SP3 and TX6.1.1.
I created an easy testplan with one sequence called "Sequence" where i can demonstrate the bug.
In Main i call "Sequence".
The call is inside of a testgroup.
The called sequence only contains a Testgroup and a DummyStep inside of the testgroup (called "SequenceDummyStep")
Then enabled tracing for the testgroups and steps to see what happens.

The tracing looks like this:

Test: Starting group MainGroup setup
User Trace: -------------------------------------------------------MainGroup
Test: Finished MainGroup setup
Test: Starting group SequenceGroup setup
User Trace: -------------------------------------------------------SequenceGroup
Test: Finished SequenceGroup setup
Test: Starting test SequenceDummyStep
Test: Finished test SequenceDummyStep
Test: Starting group SequenceGroup cleanup
Test: Finished SequenceGroup cleanup
Test: Starting group MainGroup cleanup
Test: Finished MainGroup cleanup
Test: Starting group MainGroup setup
User Trace: -------------------------------------------------------MainGroup
Test: Finished MainGroup setup

Test: Starting test DummyStep
Test: Finished test DummyStep
Test: Starting group MainGroup cleanup
Test: Finished MainGroup cleanup



The red part is wrong executed from testexec. The cleanup of the testgroup "MainGroup" is running before all steps in the group are executed (The step "DummyStep is also inside MainGroup).
The big problem is, that this cleanup also opens all switches and setup closes them again.

Is this a bug or do i use something wrong here? When will there be a fix available?
It looks like as if this happens only if you use a testgroup inside the called sequence.

Attached the testplan that creates a tracing as mentioned above.
best regards  

Attachments

Outcomes