AnsweredAssumed Answered

Benchlink Pro can't find LAN-connected instrument

Question asked by atemp on Sep 30, 2010
Latest reply on Oct 1, 2010 by atemp
This is a crosspost from another subforum here. There is no separate forum for instruments like the 34980A DMM mainframe, but Programming/Remote Communications (scopes) seems pretty close.

My problem: trying to get the 34980A DMM to talk to Benchlink Pro thru more than just a USB connection.

1- IO Libraries 15.5 Connection Expert discovers and enumerates the 34980A okay when connected via USB.
2- Benchlink Pro discovers and connects to 34980A through USB interface.
3- Connection Expert discovers and enumerates the 34980A okay when connected via LAN; can access 34980A thru its web-server interface.
BUT:
4- Benchlink Pro can't discover or connect to 34980A through LAN interface.

A dump from the BP find log reads:
12. Searching GPIB stopped due to error
11. Error occurred on GPIB. Message is (Expression does not match any devices.)
10. Searching GPIB
9. Searching USB stopped due to error
8. Error occurred on USB. Message is (Expression does not match any devices.)
7. Searching USB
6. Searching LAN stopped due to error
5. Error occurred on LAN. Message is (Expression does not match any devices.)
4. Searching LAN
3. Searching GPIB stopped due to error
2. Error occurred on GPIB. Message is (Expression does not match any devices.)
1. Searching GPIB

Yet when I turn around and plug the 34980A back in via USB, everything's fine again and BP can find & use it.

Agilent Support is taking their sweet time getting back to me about this. Any ideas or suggestions?

//Alex Templeton
Coinstar, Inc.  

Outcomes