AnsweredAssumed Answered

ADS on Ubuntu

Question asked by viking on Jan 31, 2020
Latest reply on Feb 25, 2020 by viking

I was wondering if anyone has attempted to install ADS on Ubuntu 18.04 or any other Linux OS which is other than that recommended by Keysight?

I have tried this and installed the *.so library files when ADS complained about missing dependencies but while my install works, it's buggy.

How do I force ADS to load its library files from a particular directory? Where does ADS look for library files first?

How do I find which files ADS needs?

I'm thinking that the way to solve this problem is to provide ADS with its dependencies from a CentOS7 or Redhat 7 installation but I would also need to require ADS to load those files on startup.

I suspect that my root problem is that ADS is grabbing its dependencies from my Ubuntu OS and those dependencies are of the wrong version.

I am running ADS2017 ver 1.1 on Ubuntu 64 bit 18.04

Linux ******hostname***** 4.15.0-76-generic #86-Ubuntu SMP Fri Jan 17 17:24:28 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux


Also, has anyone gotten ADS to run from a Docker container? I tried this but could not get ADS to find the license from within the container and its license app crashed under Docker with CentOS7.

Any ideas are much appreciated!