AnsweredAssumed Answered

Calibration config for GCA cal

Question asked by andyTPE on Nov 1, 2010
Latest reply on Nov 12, 2010 by andyTPE
I ma having a problem programming up a guided calibration system for the GCA cal.  I have a GCA on a channel and then start the guided cal process as follows:

1. Verify that my specified cal kit is valid against the connectors specified for the dut.
2. Assign the dut ports to connectors and cal kits as:
sens<ch>:corr:coll:guid:conn:port<portNum> '<connector>'
sens<ch>:corr:coll:guid:ckit:port<portNum> '<calkit>'
3. I then query the connector and cal kit to make sure there are no problems
4. I then want to specify the Cal method and Thru method (similar to a regular small signal S-parameter cal), so that I can control whether I have a 2port cal or an Enhanced response cal.  When I try to send:
sens<ch>:corr:coll:guid:path:tmethod 1,2,'<ThruType>'
sens<ch>:corr:coll:guid:path:cmethod 1,2,'<CalType>'
The PNAX complains with error +219

The above routine works with a standard calibration (i.e. S-parameters).  Are there some commands to select whether to perform 2port or Enhanced response specific to the GCA?  I am running A.09.22.02.  For the full, sordid details of how the VNA is configured, I have attached the IO Libs traffic dump as a zip file (raw xml exceeded attach limit).  If this is insufficient description of the problem please let me know.

Thanks for any light that can be shed....

Andy  

Attachments

Outcomes