AnsweredAssumed Answered

PNA-L N5230A Screen Blank

Question asked by DHealy on Nov 7, 2019

Hi,

A few week ago our Test & Measurement department recently received a N5230A PNA-L (300kHz - 20GHz) from another part of our company after company resources were restructured and re-distributed. There was no mention of any issues with this instrument prior to receiving it. Initially when I powered it up a few weeks ago for the first time, all of the front panel buttons were locked out including the Local key and the touch screen. The mouse worked for selecting items on the screen. Initially I thought that this was caused by a 'Local Lockout' command, but this was not the case. Eventually I just re-booted the instrument and it worked after that.

 

Yesterday, I went to use the instrument and the screen was blank but the green power light was on and the yellow LED was blinking over port 1 as it should be. I thought that it may have been some power saving mode but all button presses would not wake up the screen. I held in the power button for about 4 seconds to power down the instrument and then I powered it back up again but the screen still stayed blank. 

 

When I connected an external monitor to it via the VGA connector, the monitor had nothing on it. Rebooting the PNA-L again, the external monitor showed the 'Agilent' logo, and eventually the 'Windows XP' logo but then the external monitor wnt blank again ( PNA-L screen always blank). After about another 15 seconds the PNA-L attenuator clicks and the yellow LED start blinking over port1. I was able to boot up 'Windows XP' in 'Safe Mode' and view it on the external monitor.

 

I had a search on this forum and found an old thread 

https://community.keysight.com/thread/3147 which had a similar sounding problem. The calibration on the instrument had expired in the summer, so I decided to check out the 2 Amp fuse on the inverter board that was mentioned in the thread ( fuse circled in picture in thread next to connector CN1 ). I followed the service guide manual to remove the front panel and get access to this pcb. I measured the fuse and found that it had a resistance of 100 ohms!!

 

Is this a fuse or is it some current limiting diode?

Do you have a manufacturer number for this part?

 

I did not change it as I did not know what the part is as I was expecting a fuse to have a very low resistance if it is still good or be open circuit if blown. I was also unable to measure the voltages on the connectors CN1 & CN2 on the inverter board as all of the ribbon cables are too short to re-connect the display panel and safely probe the connector pins. 

 

Could you answer the questions about the fuse on the inverter board and also do you have any suggestion as to what the issue may be?

 

Thanks,

Declan

Outcomes