AnsweredAssumed Answered

PNA-x Ref marker wrong value for Phase format traces

Question asked by rok on Nov 5, 2019
Latest reply on Nov 5, 2019 by rok

Hello,

I am using the A model pna-x with the latest PNA_A106503 firmware installed. The issue I am having is getting the proper reading from the 'Reference' marker for a S21 Phase format trace. I've attached an image to show what I mean.

 

I'm sending a command to select Tr 65. When I send the command to read the Reference Marker, it shows +2.0242810822E+000' in the 'Agilent Interactive IO' dialog session history area. But you can see that the on-screen marker shows that it should be 115.82 degrees. I then send a command to read marker 4 value, which it correctly returns the value of ~121.99 degrees. I also send a command to read the delta marker 8 value as well, which it also correct reads as ~2.51 degrees. I then send the command to read the x value of the reference marker, which it correctly reports back as -13. But when I try to read the Reference marker y value again, it still shows the incorrect value. 

 

I tried both 'PhaseU' and 'Phase' formats, but still get similar results with respect to the reference marker. If someone can verify this, that would be greatly appreciated.

Outcomes