AnsweredAssumed Answered

Problem to select PNA measurement on Channel 2

Question asked by jem on May 13, 2011
Latest reply on May 13, 2011 by daras
Hi there,

I tried everything I could think of, I search about it without success, I need your help... Here is the situation:

I have a PNA N5242 on which I have a S22 measurement on Channel 1 (1 data points at 4.8GHz) and a S33 measurement on Channel 2 (801 data points between 50MHz to 26.05GHz).

I use a computer to record the measured data via a Labview software. I use the "Agilent PNA Series" instrument library.

To select the measurement on Channel 1, I send this command:
:CALC1:PAR:SEL "CH1_S22_1";
At that point everything works
Then to select the measurement on Channel 2 I send this command:
:CALC2:PAR:SEL "CH2_S33_3";
Here I get an error# 118: "Measurement does not belong to specified channel"

I checked if I could read these measurements by asking the PNA. For channel 1 I send this:
:CALC1:PAR:
and I get this string:
CH1_S22_1,S22
which match my measurement name. All good

For channel 2, I send this
:CALC2:PAR:
and I get this string:
CH2_S33_3,S33
which match the measurement name I previously used... So the measurement I'm trying to select is on Channel 2 based on this...

I also tried the exact same thing on a N5230A PNA with the exact same results....

If anyone has an explanation on this behavior...

Thanks
Jeremie  

Outcomes