AnsweredAssumed Answered

Oscilloscope Long time log. issue with ":Save:Image" cmd

Question asked by john_s on Jun 14, 2019

Good day, 

 

 I have made a LabView application that is able to use Oscilloscope 2024A for a long time(weeks) waveform logging.

I use 0.5sec loop and each iteration I ask about triggering ":TER?", if the device is triggered than I acquire a waveform and I also save the print-screen to USB Flash disk. 

 

It works fine until I have made about one thousand print-screen. Around this number (997,1005 etc..) of print-screens, the scope starts to gives me an error and he does not save anything. The error message is common, nothing extra helpful, something like "Error Saving".

 

I use Labview Library from Keysight and this VI to save a print-screen

The whole situation is weird, I try to find some mistake in the LabView code, but without any results.

  • I have tried different Oscilloscope (also MSO-X 2024), and different USB flash disk
  • The issue is not based on long time measuring -> I have used a signal generator and made a test setup which is able to make thousand print screen in 1 hour. The result is the same as the test runs three days

 

And the weirdest fact is that after the scope starts to give me an error and I am no longer able to save the image to USB via my Labview app. It is still possible to touch save button on Oscilloscope front panel and save the image to the USB.

 

So that is my big issue with LabView and Keysight Osc. 

Thanks for any ideas or advice,

regards John

Outcomes