AnsweredAssumed Answered

SCPI error -108 when communicating with PNA-X N5245A

Question asked by jinmaodao on Apr 9, 2019
Latest reply on Apr 12, 2019 by ChengNing

Dear all,

 

I am recently building a VNA-FMR using the Agilent PNA-X N5245A tool. I'd like the analyzer does the frequency swep between certain values, and measure S21 at each frequency. To sweep the frequency, I found out an example file from Keysight website as below, and I modified based on it with LabVIEW 2017.

However, when I run the program, there is always an error message on the screen, as shown below. It says: The SCPI command received has caused error number -108 "Parameter not allowed".

 I checked the program in labview when it runs, it seems that the error happens at a certain sub vi, which is shown in the next picture (Configure frequency start stop.vi):

This sub vi description is shown here as well:

I really couldn't get the error point and don't know how to solve it. When I use the example program shown in the beginning without any change, the same error happens at the same position in the program.

 

I am new to LabVIEW and its control to the analyzer. It might be a sily question, but I still look forward to your kindly help, since it confused me for several days. I also attached my program for your reference.

 

Thanks a lot for your help!

 

PS: I also found "labviewdriver_pna_8_2_11_2009" from the NI website. Should I use some subvis from this file or not?

 

Best regards

Outcomes