AnsweredAssumed Answered

PNA 8363B TCPIP SCPI garbled data

Question asked by Avery on Jun 8, 2009
Latest reply on Jun 8, 2009 by odanzy
We are using an 3863B PNA with ver. 7.50.50 firmware and we are trying to speed up our measurements over Ethernet TCPIP using sockets and SCPI commands.  We are controlling the PNA using an SGI Altix and Linux OS with an application we have written in CPP.  We have been measuring at a single frequency and incrementing the setting of the device under test between measurements, so we need to have fast measurements and data transfer, as well as good dynamic range.  Also, we need phase as well as amplitude, so we have been trying a polar measurement, calculating log magnitude and phase from the complex voltage vector in our application, as well as two traces, one for log mag and the other for phase.  We are currently attempting to gather SNR and measurement time benchmarks for receiver IF bandwidth versus number of points, intending to average multiple points, so we can optimize measurement time versus SNR.  We are doing the averaging inside the controlling computer application as we were unable to get the PNA's averaging feature to work remotely.  The minimum number of points is two, and we have tried both CW Time and Zero Span, and set the sweep type to stepped.  In both cases, we sometimes get garbled data when the number of points and/or the bandwidth is large.  Using the marker on the PNA screen, the data always looks good, but when it arrives in the controlling application, it is sometimes garbled.  When the number of points is 21 of less, we always get good data.  We have tried inserting time delays in our controlling application code, and this does help for some of the middle cases, but the larger number-of-point cases still usually fail, but not always.  Has anyone seen this behavior before, and how did you fix it?  Do your have any other tips for speeding up this kind of measurement and data transfer?  Thanks!  

Outcomes