AnsweredAssumed Answered

DSOX1102G :HARDCopy:INKSaver command broken

Question asked by AdamL. on Nov 27, 2017
Latest reply on Dec 4, 2017 by AdamL.

I discovered that the DSOX1102G (f/w 01.01.2016092800 - the latest) doesn't support the :HARDCopy:INKSaver command per its manual.

 

You can query the command just fine; you can write to the command with the same mode the scope is in and there is no complaint; if you try to change the setting the scope gives you a "Settings conflict" popup and doesn't change the mode.

 

e.g. By default inksaver is off (dark background). If you try to turn it on with either "ON" or "1", you get the settings conflict popup. If you send "0" or "OFF" there is no error and no settings conflict popup.

 

From the programming manual:

 

:HARDcopy:INKSaver (see page 776)

 

Command Syntax
:HARDcopy:INKSaver <value>

 

<value> ::= {{OFF | 0} | {ON | 1}}
The HARDcopy:INKSaver command controls whether the graticule colors are inverted or not.

 

Query Syntax
:HARDcopy:INKSaver?

 

The :HARDcopy:INKSaver? query returns a flag indicating whether graticule colors are inverted or not.

 

Return Format
<value><NL>
<value> ::= {0 | 1}

 

I raised a ticket for this - does anyone know of any workarounds? We use inksaver as part of our internal automation for the DSO/MSO 5/6000 series and DSO-X/MSO-X 3000 series of scopes - it's handy when printing!

 

Also: no firmware updates (still on 01-01) makes me wonder if this model is soon going to end up on the 'obsolete' list...

Attachments

Outcomes