AnsweredAssumed Answered

Differing Function of automation when moving from N5244A to N5244B

Question asked by Neilfenstein on Sep 5, 2017
Latest reply on Sep 8, 2017 by Neilfenstein

I have been running my software for a couple of years now on the 'A' Model PNA-X and I had no concerns about transferring to the 'B' Model assuming all was the same.

 

However when I run my Tier 1 Cal for the phase reference (Comb Generator cal) I cannot get past the initial sweep.

 

I am certain that this shouldn't be a problem but I have been trying to figure it out for a while now and its making me sad/angry .

 

Here is an excerpt from the IO Monitor below. I am using the standard *OPC then *STB? polling method.

 

9/6/2017 12:15:17 AM [1 - VXI-11/SICL-LAN] :SYST:CAL:PHAS:RES
9/6/2017 12:15:17 AM [1 - VXI-11/SICL-LAN] SYST:CAL:PHAS:FREQ:STAR 1.0000000000E+9
9/6/2017 12:15:17 AM [1 - VXI-11/SICL-LAN] SYST:CAL:PHAS:FREQ:STOP 3.3000000000E+10
9/6/2017 12:15:17 AM [1 - VXI-11/SICL-LAN] SYST:CAL:PHAS:REF:CAT?
9/6/2017 12:15:17 AM [1 - VXI-11/SICL-LAN] "MY49230259"
9/6/2017 12:15:17 AM [1 - VXI-11/SICL-LAN] SYST:CAL:PHAS:REF "MY49230259";
9/6/2017 12:15:17 AM [1 - VXI-11/SICL-LAN] SYST:CAL:PHAS:POW:ATT 10;
9/6/2017 12:15:17 AM [1 - VXI-11/SICL-LAN] SYST:CAL:PHAS:CONN '2.92 mm male';
9/6/2017 12:15:17 AM [1 - VXI-11/SICL-LAN] SENS:CORR:CKIT:ECAL:LIST?
9/6/2017 12:15:17 AM [1 - VXI-11/SICL-LAN] +1
9/6/2017 12:15:17 AM [1 - VXI-11/SICL-LAN] :SENS:CORR:COLL:CKIT:INF? ECAL1;
9/6/2017 12:15:17 AM [1 - VXI-11/SICL-LAN] "ModelNumber: N4692-60001, SerialNumber: 14850, ConnectorType: 29F 29M, PortAConnector: 2.92 mm female, PortBConnector: 2.92 mm male, MinFreq: 10000000, MaxFreq: 40000000000, NumberOfPoints: 808, Calibrated: 03/Jul/2017, CharacterizedBy: 15N5239932, "
9/6/2017 12:15:18 AM [1 - VXI-11/SICL-LAN] SYST:CAL:PHAS:CKIT 'N4692-60001 ECal 14850';
9/6/2017 12:15:18 AM [1 - VXI-11/SICL-LAN] SYST:ERR?
9/6/2017 12:15:18 AM [1 - VXI-11/SICL-LAN] +0,"No error"
9/6/2017 12:15:18 AM [1 - VXI-11/SICL-LAN] SYST:CAL:PHAS:PORT3 ON;
9/6/2017 12:15:18 AM [1 - VXI-11/SICL-LAN] SYST:CAL:PHAS:PORT4 ON;
9/6/2017 12:15:18 AM [1 - VXI-11/SICL-LAN] :SYST:CAL:PHAS:GUID:CHAN?
9/6/2017 12:15:18 AM [1 - VXI-11/SICL-LAN] +200
9/6/2017 12:15:18 AM [1 - VXI-11/SICL-LAN] :SENS200:CORR:COLL:GUID:INIT;
9/6/2017 12:15:18 AM [1 - VXI-11/SICL-LAN] :SENS200:CORR:COLL:GUID:STEP?
9/6/2017 12:15:18 AM [1 - VXI-11/SICL-LAN] +11
9/6/2017 12:15:18 AM [1 - VXI-11/SICL-LAN] OUTP:STAT 1
9/6/2017 12:15:18 AM [1 - VXI-11/SICL-LAN] *CLS
9/6/2017 12:15:18 AM [1 - VXI-11/SICL-LAN] :SENS200:CORR:COLL:GUID:DESC? 1
9/6/2017 12:15:18 AM [1 - VXI-11/SICL-LAN] "Connect OUT of the phase reference to Port 2 and connect IN of the phase reference to the 10 MHz REF OUT of the PNA (reverse Port 2 coupler)"
9/6/2017 12:15:20 AM [1 - VXI-11/SICL-LAN] :SENS200:CORR:COLL:GUID:ACQ STAN1, ASYN;
9/6/2017 12:15:20 AM [1 - VXI-11/SICL-LAN] *OPC
9/6/2017 12:15:20 AM [1 - VXI-11/SICL-LAN] *STB?

9/6/2017 12:15:20 AM [1 - VXI-11/SICL-LAN] +0

 

Repeats until initial sweep complete then.

 

9/6/2017 12:22:05 AM [1 - VXI-11/SICL-LAN] *STB?
9/6/2017 12:22:05 AM [1 - VXI-11/SICL-LAN] +0
9/6/2017 12:22:05 AM [1 - VXI-11/SICL-LAN] ERROR -800, Operation complete;<Err>
9/6/2017 12:22:05 AM [1 - VXI-11/SICL-LAN] *STB?
9/6/2017 12:22:05 AM [1 - VXI-11/SICL-LAN] +0

 

The screen is left with no trace and the code continues to poll. I have attempted to increase the time out etc with no luck.

 

I am currently attempting a manual cal to check that I can actually cal the 'B' Model, which I did not expect to do.

 

Any ideas in the mean time may be helpful? Thanks in advance.

Outcomes