AnsweredAssumed Answered

error with serial port read/Write in VEE 9.2

Question asked by RistoT on Jan 31, 2017
Latest reply on Apr 18, 2017 by chenchoasencio

 I am running VEE 9.2.13522.0 on laptop which has Win 7 home premium. In my program I'm using direct I/O object to read data from DUT through serial port (Brainbox USB-serial adapter). This setup has been working well for a long time but yesterday windows gave an error window that VEE has stopped working. I cant remember exatly what windows error message was but i think it was that VEE has stopped responding or something like that.

 

After that I could not connect to serial port with VEE anymore.

If I connect to serial port with terminal program example Teraterm everything works, but if I run my programs in VEE it returns error 811, and if I press troubleshooter button it says "Resource(s) found on this interface but not at ASRL3::INSTR".
Serial port has following configuration: Name=COM3, Interface=ASRL, Board number=3, VISA alias = ASRL3, VISA address=ASRL3::INSTR. I have tried to remove and install COM port again with same and different COM number but it didnt change anything. Also Laptop has been booted few times after that but problem is still the same.

 

If I write to serial port it does give any error but nothing comes out of serial port. If I read serial port it gives that error 811.

 

I have attached pictures about error message and COM port configuration.

I wanted to ask if any knows what the problem is and maybe solution to this before I try to reinstall VISA or VEE.

Outcomes