AnsweredAssumed Answered

Unable to upgrade the firmware of 81150A

Question asked by cagricetintepe@gmail.com on Apr 21, 2015
Dear forum members,

In our research lab, we are in the possession of an Agilent 81150A pulse/function/arbitrary waveform generator. In an attempt to upgrade its firmware from the factory default 1.2.0.0-4 to the latest version (3.0.0.0), we noticed a strange behavior: After initiating the firmware update procedure (Utility->System->Configuration->Software update->Yes), the progress hangs at the extraction of "update.xml" (step 1/7) and fails to proceed. We have tried several USB pen drives (with FAT32 file system), different USB ports on the instrument and rebooting with an extracted firmware archive; but we could not accomplish the firmware revision.

In addition to the aforementioned issue, we observed that whenever we tried to modify (or delete) any user configuration state or stored arbitrary waveform, the instrument software simply crashes and stops responding, leaving a power cycle as the only way out. We have tried to wipe away all user-related data by issuing SECURE ALL in the instrument GUI (or its remote equivalent ":SYST:SEC:IMM") to no avail.

Has anyone come across such issues? We suspect a problem associated with the nonvolatile memory; but do not know how to proceed.

Thanks in advance.
---
Cagri  

Outcomes