AnsweredAssumed Answered

Referencing non-ADS models in Netlist files

Question asked by jgbiii on Sep 23, 2015
Latest reply on Sep 30, 2015 by jgbiii
So I have been struggling with this for a long while and I have tried contacting support several times and I can never get the answers that I want.  For the work that I am doing I have to run an ADS simulation on a netlist I created through the command line.  I am able to successfully run this simulation and view the results with built in ADS models, however when I use a different companies models for example, Modelithics amplifier models I get the simulation error: "`HMT_EUD_EGN030MK_MDLXNLT1.C_FET1' is an instance of an undefined model `C_FET8'.  

Sample code for my command line:
set HPEESOF_DIR=c:\ADS\ADS2013_06
set COMPL_DIR=c:\ADS\ADS2013_06
set MDLXNLT1=c:\...\MDLX_NLT_dk_Library  (*) Not needed for built in models
set SIMARCH=win32
hpeesofsim -r H:\...\output.log H:\...\netlist.log

Sample of model in my netlist file:
#uselib "MDLXNLT1" , "HMT_EUD_EGN030MK_MDLXNLT1"
"HMT_EUD_EGN030MK_MDLXNLT1":EGN030MK_1  N__5 N__6 0 TEMP=25 

The environmental variables I set:
'C:\ADS\ADS2013_06\bin';
'C:\ADS\ADS2013_06\adsptolemy\lib.win32';
'C:\ADS\ADS2013_06\lib\win32';

I have attempted adding MDLXNLT1 path to my "ADSlibconfig" file and I get the same error listed above.  I guess the main question is how do I properly reference a 3rd party library in a netlist file so that I can get a simulation to converge from the command line.  I would appreciate any advice pointing me in the right direction as I feel like I have been banging my head against the wall with this.

Edited by: JGBIII on Sep 23, 2015 4:37 PM

Edited by: JGBIII on Sep 23, 2015 4:39 PM  

Outcomes