AnsweredAssumed Answered

E4406A: Fails firmware upgrade for version 8.10 and greater

Question asked by swperk on Feb 22, 2015
Latest reply on Mar 23, 2015 by simon_coleby
I recently acquired an E4406A with firmware version 7.05, s/n US3903xxxx, and it works fine, boooting without errors, self-aligning without a problem, and working as it should.

Since the latest firmware is 10.08, I decided to upgrade the firmware in this instrument. However, when I tried to upgrade, I noticed that at the very end of the upgrade, the status messages said that there were several files that it was unable to create. Even so, the final message on the screen after the upgrade was that the upgrade was complete and I should power cycle and reboot the instrument.

When I restarted the instrument, I was watching the boot screen and noticed a messsage that I hadn't seen before. It said:

                 vsa
                 vsa: bad value

but continued to boot.  Eventually I heard the attenuator relays click, and it got to the blank white screen just before it would have started the self-testing. It didn't get there, though, and stopped with the following message on the screen:

                 users/arcturus/.xinitrc: 57 memory fault
                 Firmware exit, cycle power

Restarting produced the same results. I also tried installing firmware version 8.10 Release 2 by using the "non-functional instrument" option on the installer, but got the identical results as with the 10.08 firmware. Finally, I reverted back to the 7.05 firmware, again by using the "non-functional instrument" option, and my E4406A is back to working fine.

Does anyone know what might be causing this? Was there a significant change in firmware between 7.05 and the later versions that might explain this incompatibility? Any ideas of what to check next? I have another E4406A that I have sucessfully upgraded to 10.08, so I'm pretty confident that I know the procedure, but any and all suggestions would be appreciated.

Thanks,
Stan

Edited by: swperk on Feb 22, 2015 8:22 AM  

Outcomes