AnsweredAssumed Answered

Thermocouple measurements with 34921T

Question asked by drdroege Employee on Feb 18, 2014
Latest reply on Feb 18, 2014 by tomc
Hi,
I have a 34980A with a 34921A and 34921T.

I'm having difficulty getting the temperature to measure correctly and I suspect that it's due to the reference.
With this arrangement, I should set the reference to INTernal, but that option does _not_ appear via the keyboard nor via the lan-based GUI.  On the other hand, when I select a reference of Fixed, the ambient temperature is displayed as about -2C (little too cold for our lab), and with the reference is set to EXTernal, the display is -OVERLOAD.
I've double-checked the wiring and all looks good.  In addition, I tried another 34921T with other thermocouples and I get the same result.

More info:
J-Type thermocouples
34980A Firmware: 2.43-2.43-2.07-1.05
34921A Firmware: 1.21

Thanks,
David

Edited by: drdroege on Feb 18, 2014 4:13 PM
As suggested, I used SCPI commands to set: 
CONF:TEMP TC,J,(@)
and
SENSe:TEMPerature:TRANsducer:TCouple:RJUNction:TYPE INT, (@2001)  (btw, using the (@) without a channel gives an 'out-of-range' error; I have thermcouples on the first 6 channels in the 34921T).
but the temperature that the DMM is returning is still not correct (~-3.2C).
I used SCPI commands to query the Type to ensure that it was being set to INT and it was though, for some reason, the 34980A keypad menu still indicates that it is FIXed.
There were two modules in the 34980, the 34921A was in slot 2 and I had a 34925A in slot 1.  To assist in troubleshooting, I've removed the 34925A and inserted the 34921A/T in slot 1 and am still getting the same (~2degC) temperature.

Note: Prior to the DMM measurment, I am closing the thermocouple relay (1001 or 2001) and the bus relay (1911 or 2911) depending on the slot that the module is in.  

Outcomes