AnsweredAssumed Answered

Problem in generation pulse signal from PNA.

Question asked by rohit on Aug 19, 2013
Hello Everyone,


I am facing problem in generating pulse signal from my PNA 5242A. Below is the description of the problem

Below listed are two method in which I am trying to generate Pulsed RF signal from the PNA
A.If I send the below SCPI command to the PNA (5242A), my PNA gets set in Narrow Band and hence the IFBW gets set to 50Hz, due to which I get a lot of noise in my response from the DUT. Ideally IFBW>= (1/Ton) which is >= 100 kHz for my pulse width of 10usec.

SCPI Command:

1. SENS1:SWE:PULS:MAST:PER 0.01 to set pulse period
2. SENS1:PULS1:WIDT 0.00001 to set pulse width
3. SENS1:SWE:PULS:MODE STD to set Standard pulse
4. SENS1:PULS0 1
5. SENS1:PULS1 1
6. SENS1:PATH:CONF:ELEM:STAT "PulseModDrive","Pulse1"
7. SENS1:PATH:CONF:ELEM:STAT "Src1Out1PulseModEnable","Enable"
So in order to set my DUT in Wide-band, I send another SCPI command and set the DUT in Wide-band and hence my IFBW also gets set to 150 kHz but I stop getting response from the DUT, unless I manually go to Pulse Setup window and click the Ok button, upon clicking of which I get good response from DUT



B.If I use this below set of SCPI commands in order to set pulse in the PNA (5242A)

SCPI Command:

sens:puls1:per .005
sens:puls1:widt .001
Sens:puls1:del .00025
sens:bwid 600000
sens:puls1:stat on
sens:puls0:stat on
sens:path:conf:elem 'Src1Out1PulseModEnable','enable'
sens:path:conf:elem 'PulseModDrive','Pulse1'
I am able to set my PNA is wide band and hence the IFBW gets set to 150 kHz, but I don’t get response from my DUT, unless I manually go to Pulse Setup window and click the Ok button, upon clicking of which I get good response from DUT.


What could be going wrong in my SCPI command?
Any help will be highly appreciated.:) 


Regards,
Rohit.  

Outcomes