AnsweredAssumed Answered

RE3: vrf From String Bug

Question asked by VRFuser on Sep 21, 2007
Stan Bischof (Richard S) <rsb@soco.agilent.com> wrote:
> William.Drago@L-3com.com wrote:
> > Exactly! It only adds a CR when it doesn't find the excluded chars,
> > which is very strange. I would consider this a bug especially since
> > not everyone sees the problem.
>
> As a user I would have to also agree that this is a bug. I normally
> just throw in "
" when reading with token format, though I suppose
> this would break cases where the string intentionally has embedded LF's.
>
> In any case, this has been the behavior for a very long time.
> I tried it back in version 3 and it worked exactly the same.
> No easy way to fire up earlier versions here ( perhaps the VEE team
> can ?) but it is probably safe to say it has always acted this way.
>
> I would certainly add my vote to see this fixed-- it has to be
> something pretty simple so can't be a big deal to fix. And it would be
> one more minor item out of the way!

Interestingly this is even documented but not explained.

Page 513 of the 2004 edition of VEE Advanced Techniques shows an example of exactly what we are looking at - that includes the extra LF at the end. But the example does not appear to explain _why_ the character is there, while it does explain the rest of the behavior in great detail.

Stan



--------------------------------------------------------------------------
Stan Bischof  Agilent Technologies  707-577-3994  stan_bischof@agilent.com
--------------------------------------------------------------------------

---
You are currently subscribed to vrf as: ming_meng@agilent.com To subscribe please send an email to: "vrf-request@lists.it.agilent.com" with the word subscribe in the message body.
To unsubscribe send a blank email to "leave-vrf@it.lists.it.agilent.com".
To send messages to this mailing list,  email "vrf@agilent.com". 
If you need help with the mailing list send a message to "owner-vrf@it.lists.it.agilent.com".
Search the "unofficial vrf archive" at "http://www.vrfarchive.com/vrf_archive".
Search the Agilent vrf archive at "http://vee.engineering.agilent.com".

Outcomes