AnsweredAssumed Answered

Problem with the 81150A

Question asked by JPorem on Mar 22, 2010
Latest reply on Mar 31, 2010 by lhornburg
I am currently using the 81150A and am encountering a strange error. I have a GPIB interface setup and programmed a set of instrument commands I need. I had it all working on the machines I was programming on, and had an install package and everything for a second machine.

Now though, on the second machine, I am getting a strange error.

"
unable to cast COM object of type 'FGPG' to interface type 'Agilent.Agilent81150.Interop.IAgilent81150_2' [...] no such interface supported
"


FGPG is my Agilent81150Class object, and the interface seems to be referring to channel 2 (it is a channel call this is getting hung up on). I removed the [...], it was referencing the specific address of the instrument.

Anyone encounter this before? It compiles perfectly, and I have tested the same setup with a different 81150A and still get the same error. This would indicate there is a problem with the IVI drivers (it seems), but this machine has the exact same ones I was using...  

Outcomes