AnsweredAssumed Answered

34410 SAMP:TIM cannot be set.

Question asked by narenst on Mar 18, 2011
Latest reply on Apr 4, 2011 by lhornburg
I'm using the linux driver to connect to 34410A.

My code (in perl) looks like this.

       my $echoresult =  `echo 'SAMP:SOUR TIM'>/dev/usbtmc1`;
        $echoresult =  `echo 'SAMP:TIM 0.01'>/dev/usbtmc1`;
        $echoresult =  `echo 'SAMP:COUN 300'>/dev/usbtmc1`;
        $echoresult =  `echo READ? >/dev/usbtmc1`;


Even though I'm setting the SAMP:TIM as 0.01 it is not getting set correctly. When I query SAMP:TIM?, it is returning 0.01. But when READ? is executed, the TIM value is roughly 0.1 second.

Can anyone suggest a solution for this? Am I not setting some parameter?

If this is not confusing, I also tried to set "SAMP:TIM MIN". And when I not query SAMP:TIM? the value is about 0.3 second. Not sure why?

Thanks in advance!  

Outcomes