AnsweredAssumed Answered

vrf Direct I/O Lan configurations

Question asked by VRFuser on Jan 11, 2008
Michael,

You could configure the instument's IP in VEE Instument Manager menu. My method simply gives you the flexibility of programatically changing the IP, as I always do.

Either way should work, but if you still have a problem you may send a snippet of your code with the I/O config that you are having problem with, and I can look into it.

-Vinod

--- Michael Ford <michael.ford@comtechpst.com> wrote:

> I am using VEE 8.  I/O Lib 14.2.  I solved my problem by using
> Sockets, but I would like to know what is wrong.
>

>
> *         I set up my VEE instrument Manager with an IP address exactly the same as I
> set up Agilent Connection Expert.
>
> *         The Agilent Connection Expert achieves connection, but the VEE Instrument
> Managers gives me the "no instrument or interface found" error message.
>

>
> I have already received a VRF reply from Vinod. The difference in his
> example is that he is setting this command in a function object.
> IO.SA1.visaAddress = "TCPIP0::"+value+"::inst0::INSTR"; Unfortunately,  I haven't had the time to try this.
>

>

>

>

>

>
> Michael Ford
>
> Test Engineer
>
> Comtech PST Corp.
>
> 105 Baylis Rd. Melville NY, 11747-3833
>
> Email: michael.ford@comtechpst.com
>
> Phone: 631 486-4108
>
> Fax:     631 777-8877
>
> www.comtechpst.com <http://www.comtechpst.com/>
>

>
> ________________________________
>
> From: Baranski, Detlef [mailto:Detlef.Baranski@pilkington.de]
> Sent: Wednesday, January 09, 2008 10:42 AM
> To: Michael Ford; VRF
> Subject: AW: [vrf] Direct I/O Lan configurations
>

>
> Are you using DirectIO 15.0 now ? And what vee version ?
>
> Or is your problem solved over the years
>
> detlef
>

>
> ________________________________
>
> Von: Michael Ford [mailto:michael.ford@comtechpst.com]
> Gesendet: Donnerstag, 3. Januar 2008 19:32
> An: VRF
> Betreff: [vrf] Direct I/O Lan configurations
>
> Does anyone have an example of using a Direct I/0 object with LAN (TCPIP).
>

>
> I'm coding a new R&S ZVL that does not have a GPIB interface. I would
> like to use the LAN interface.
>
> I've established *IDN? Responses when using the Agilent Connection
> Expert, but I can't get the VEE instrument manager to recognize this interface at all.
>

>
> Michael Ford
>
> Test Engineer
>
> Comtech PST Corp.
>
> 105 Baylis Rd. Melville NY, 11747-3833
>
> Email: michael.ford@comtechpst.com
>
> Phone: 631 486-4108
>
> Fax:     631 777-8877
>
> www.comtechpst.com <http://www.comtechpst.com/>



      ____________________________________________________________________________________
Looking for last minute shopping deals? 
Find them fast with Yahoo! Search.  http://tools.search.yahoo.com/newsearch ... y=shopping


---
You are currently subscribed to vrf as: ming_meng@agilent.com To subscribe please send an email to: "vrf-request@lists.it.agilent.com" with the word subscribe in the message body.
To unsubscribe send a blank email to "leave-vrf@it.lists.it.agilent.com".
To send messages to this mailing list,  email "vrf@agilent.com". 
If you need help with the mailing list send a message to "owner-vrf@it.lists.it.agilent.com".
Search the "unofficial vrf archive" at "http://www.vrfarchive.com/vrf_archive".
Search the Agilent vrf archive at "http://vee.engineering.agilent.com".

Outcomes