AnsweredAssumed Answered

E5071C ECal Orientation Bug?

Question asked by mhreider on Jan 23, 2013
Latest reply on Feb 26, 2013 by takeshio
This was on an E5071C Analyzer running firmware 11.02. 

So I ran into an issue with the SCPI Commands for ECal orientation. Instead of using the automatic 4-port sensing functionality when SENS:CORR:COLL:ECAL:ORI is set to 1 and SOLT4 is run, I:

Use SENS:CORR:COLL:ECAL:PATH? to query the path orientation for each individual combination and declare the paths myself after disabling orientation. This allows me to add some error checking functionality to some of our more exotic setups to make tracing an incorrect connection easier. 

However, It seems numeric 1, numeric 2 are changing depending on whether orientation is enabled or not. With orientation on, it should be "ECal Port, VNA Port". With it off, I'm getting "VNA Port, ECal Port"

So here's a short example to clarify: 
-> SYST:PRES
-> SENS:CORR:COLL:ECAL:ORI ON
-> SENS:CORR:COLL:ECAL:PATH? 3
<- +4
-> SENS:CORR:COLL:ECAL:ORI OFF
-> SENS:CORR:COLL:ECAL:PATH? 3
<- +0
-> SENS:CORR:COLL:ECAL:PATH? 4
<- +0
-> SENS:CORR:COLL:ECAL:PATH 4,3
-> SENS:CORR:COLL:ECAL:PATH? 3
<- +0
-> SENS:CORR:COLL:ECAL:PATH? 4
<- +3

I noticed this when I was having problems with some poor performing calibrations. Am I interpreting the documentation wrong here or is this a bug? Here's the excerpt from the documentation I'm referring to as well. 

*Syntax*
*:SENSe{[1]-160}:CORRection:COLLect:ECAL:PATH ,*
*:SENSe{[1]-160}:CORRection:COLLect:ECAL:PATH? *

Thanks,
Matthew

Outcomes