AnsweredAssumed Answered

Netlist include does not work

Question asked by JustAGlitch on Mar 13, 2012
Latest reply on Mar 20, 2012 by eyeung
Hello, I have a SPICE/Spectre subcircuit for a 2-port passive component.
I have tried to use it in ADS 2011.10 via netlist import and the Netlist include element.
I have followed all the instructions in the document "Netlist Translator for
SPICE and Spectre", and the the resulting ADS netlist looks fine.

But in spite of this, when I try to use the resulting component in an S-parameter
simulation, I get a warning in the simulation status window:

Number of nodes with only one device attatched (topology corrected): 2

and the simulation results are zero. What is going on here, what am I missing?
I have tried renaming the two ports that appear together with the netlist include
element, but no joy.

BTW, I really think Agilent should have a proper example of how to include a
SPICE subcircuit. The only example I could find was for a MOSFET model
statement and not for an equivalent circuit.

I have attatched the Spectre and ADS netlists for the component (a capacitor).  

Attachments

Outcomes