AnsweredAssumed Answered

Problems updating (well downgrading) firmware on N9923A

Question asked by drkirkby on Oct 6, 2012
Latest reply on Oct 6, 2012 by drkirkby
I have a FieldFor N9923A VNA, which was shipped from Agilent with firmware  A.06.02. But as was pointed out by am95405, this firmware version does not work with the Data Link software. So I tried to downgrade the firmware from A06.02 to A.05.51, which is the latest I can find for that instrument. (It seems Agilent have pulled A.06.02 from the web site in the last 24-48 hours). 

But my efforts to change the firmware version are always failing. This is what I've done. 

1) Downloaded the file http://na.tm.agilent.com/fieldfox/download_files/N9923A_A.05.51.ZIP to the hard disk on my Windoze 7 laptop. 
2) Extracted the file using Winzip to the root (top-level) directory of the USB stick. This creates a single file "N9923A" of 39,964 kB.
3) Powered the N9923A right off - *NOT* standby.
4) Inserted the USB stick into the N9923A
5) Powered on the N9923A. After the bootup process, it loads the network analyzer application. It does *not* go into any menus where I can change the firmware version.
 
After this did not go into any software to update the firmware, I've tried various things. 

a) Changed the USB slot. 
b) Changed the USB stick. I've used 5 in total: 

* One badged "Duracel" (32 GB)
* Another badged "Sandisk" (16 GB)
* Another badged "SSK USB 3.0" (64 GB)
* Another badged  "Ansys", which was supplied to me when attending a course by Ansys on HFSS. I can't recall the size of this, but it is probably 8 GB or less. 
* Yet another badged "Ansys" - from yet another HFSS course. 
 
c) Reformated the Sandisk USB stick as FAT32, and extracted the Zip file to that for a second time. 

*Not one of these has  worked.* 

I guess if I hunt around my house, I'll find some more memory sticks, but I would have thought trying 5 (admittidly the two Ansys ones are probably the same, as they look identical), I should be able to change the firmware version. 

The N9923A I have is S/N US49470148. It was bought on eBay dirrectly from Agilent as a "Certi Prime" unit. It has options 

* 308 Vector voltmeter
* 305 Cable amd Antenna Analyzer
* 302 Power meter
* 112 Quckcal
* 010 Time domain
* 122 Full S parameters
* 106 6 GHz. 

(I believe they are all the options, though there might have been one released since I paid for the unit about a month ago). 

I tried saving a file to one of the memory sticks. That worked fine. When I looked for files in the VNA, it see the file N9923A. 

If someone at Agilent has a memory stick that definately does work, perhaps they could stick me one in the post. You should be able to get my address from the Agilent order number 3192983. I've stuck my real name below too. 

Any other ideas? 

Dr. David Kirkby  

Outcomes