AnsweredAssumed Answered

Using Signal Studio for Pulse Building to connect to N8241A

Question asked by mlow on Aug 30, 2011
Latest reply on Sep 9, 2011 by mlow
Hi,

I am trying to use Signal Studio for Pulse Building to connect to the N8241A Wideband Arb and E8267D Vector Signal Generator.  Using the System Configuration Wizard, I can connect to the E8267D ok, but when I try to connect to the N8241A, it uses the command "TCPIP0::192.168.1.101::4000::SOCKET", which fails.  When I use the Agilent Connection Expert, I can connect to the N8241A just fine, because it uses the command "TCPIP0::192.168.1.101::inst0::INSTR".  In the System Configration Wizard, I tried to select "Choose an External Wideband Arb from list of configured interfaces in IO libraries", I can see the selection "TCPIP0::192.168.1.101::inst0::INSTR", but Pulse Building goes ahead and issues the command "TCPIP0::192.168.1.101::4000::SOCKET" anyway.

I am using Pulse Building version 1.2.28 (I have also tried 1.3.25), and Agilent IO Libraries version 15.0.  I have tried uninstalling and reinstalling all relevant software without luck.

The strange thing is that this same configuration works on two other laptops.  In this case, the software was installed several years ago.  I don't understand what is forcing Pulse Building to issue the "SOCKET" command, or how I can change it.

Any assistance appreciated.

Thanks,
Mike  

Outcomes