AnsweredAssumed Answered

AW: vrf Create Directory

Question asked by d.sperling on Jun 27, 2005
Thanks to a clue from Willie Kiely <Willie.Kiely@bourns.com>, I
figured out that VEE 7.5 currently only supports older National Instruments
hardware.  Specifically, it only supports hardware that can be programmed
with the "Traditional NI-DAQ (Legacy)" driver.
      So, I added an older NI PCI-MIO-16E-1 to my system, VEE found it, and
I was able to acquire data.
      I also added a National Instruments PCI-5431 video signal generator
to my system.  That worked pretty much "out of the box".
      I haven't used VEE 7.5 much, but my impression is that Agilent's done
a better job integrating NI's instruments (scopes, DMMs, arbs, etc.) than
they've done integrating NI's general purpose DAQ boards.  I suspect the
VEE team is working on support for NI-DAQmx, which should improve usability.

Brian

"Brian H. Powell" wrote...
>      I've got VEE 7.51 and a National Instruments PCI-6251 Data
> Acquisition card.  I'm getting an error trying to do a simple read.  I
> think I'm just confused about what to do.  Anybody have any advice or
> experience?
>      I'm using I/O -> Instrument Manager.  "Find Instruments" doesn't see
> this device, but it does find a couple of other devices (a 34401A and a
> National Instruments PCI-5431 arb).  I've tried setting up the NI-DAQ
> device manually in the Instrument Manager, and I think I'm just not doing
> that correctly.
>      The error I'm getting says...
>
> Error returned from NIDAQ NIxxxx_init() function call, error value
0xbfff0012
>
> Error number: 818
>
> NI-DAQ Error 18: Unknown NI-DAQ error code.
>
> Error returned from calling init function:
>   AGniDaq_init("Dev1", FALSE, TRUE, &handle);
> Possibly, the configured address string is incorrect. The address
> should be in the form 'DAQ::<deviceNumber>' or 'PXIn::<deviceNumber>'
> or 'SCXIn::<deviceNumber>'. Check the deviceNumber in NI MAX.
> Also, check the instrument connections and power.
>
>      In MAX, the device is called "Dev1".  I also tried changing the value
> in VEE to "DAQ::0" with the same error.  ("DAQ::1" refers to the
> PCI-5431.)  I also tried renaming my device in MAX from "Dev1" to "DAQ::0",
> but that's not a legal name.
>      By the way, I'm running NI-DAQ 7.3.
>      Also, is there an official list of National Instruments devices that
> are supported in VEE?  My 6251 is a pretty new device; maybe VEE just
> doesn't support it yet.
>      Thanks for any help or advice.
>
> Brian


---
You are currently subscribed to vrf as: rsb@soco.agilent.com
To subscribe send a blank email to "join-vrf@it.lists.it.agilent.com".
To unsubscribe send a blank email to "leave-vrf@it.lists.it.agilent.com".
To send messages to this mailing list,  email "vrf@agilent.com". 
If you need help with the mailing list send a message to "owner-vrf@it.lists.it.agilent.com".

Outcomes