AnsweredAssumed Answered

vrf Vee Pro 6.03 runtime slowing down at midnight.

Question asked by VRFuser on Apr 6, 2005
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"><HTML><HEAD><META http-equiv=Content-Type content="text/html; charset=iso-8859-1"><META content="MSHTML 6.00.2800.1491" name=GENERATOR><STYLE>@font-face {     font-family: Tahoma;}@page Section1 {size: 8.5in 11.0in; margin: 1.0in 1.25in 1.0in 1.25in; }P.MsoNormal {     FONT-SIZE: 12pt; MARGIN: 0in 0in 0pt; FONT-FAMILY: "Times New Roman"}LI.MsoNormal {     FONT-SIZE: 12pt; MARGIN: 0in 0in 0pt; FONT-FAMILY: "Times New Roman"}DIV.MsoNormal {     FONT-SIZE: 12pt; MARGIN: 0in 0in 0pt; FONT-FAMILY: "Times New Roman"}A:link {     COLOR: blue; TEXT-DECORATION: underline}SPAN.MsoHyperlink {     COLOR: blue; TEXT-DECORATION: underline}A:visited {     COLOR: #606420; TEXT-DECORATION: underline}SPAN.MsoHyperlinkFollowed {     COLOR: #606420; TEXT-DECORATION: underline}P {     FONT-SIZE: 12pt; MARGIN-LEFT: 0in; MARGIN-RIGHT: 0in; FONT-FAMILY: "Times New Roman"}SPAN.EmailStyle18 {     COLOR: navy; FONT-FAMILY: Arial}DIV.Section1 {     page: Section1}</STYLE></HEAD><BODY lang=EN-US vLink=#606420 link=blue bgColor=#ffffff><DIV><FONT face=Arial size=2>Ladies and Gentlemen,</FONT></DIV><DIV><FONT face=Arial size=2>I have 14 VEE Data Acquisition Apps. running around the clock using VEE versions 4 - 7 and Windows 95, NT, and XP.</FONT></DIV><DIV><FONT face=Arial size=2>The VEE apps acquire data every 15 minutes to every hour depending on the test specification.</FONT></DIV><DIV><FONT face=Arial size=2>I have not encountered this problem. </FONT></DIV><DIV><FONT face=Arial size=2>Bob</FONT></DIV><DIV>----- Original Message ----- </DIV><BLOCKQUOTE style="PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">  <DIV   style="BACKGROUND: #e4e4e4; FONT: 10pt arial; font-color: black"><B>From:</B>   <A title=tranh@tycoelectronics.com   href="mailto:tranh@tycoelectronics.com">Tran, Han</A> </DIV>  <DIV style="FONT: 10pt arial"><B>To:</B> <A title=vrf@agilent.com   href="mailto:vrf@agilent.com">VRF</A> </DIV>  <DIV style="FONT: 10pt arial"><B>Sent:</B> Tuesday, April 05, 2005 7:50   PM</DIV>  <DIV style="FONT: 10pt arial"><B>Subject:</B> RE: [vrf] Vee Pro 6.03 runtime   slowing down at midnight.</DIV>  <DIV><BR></DIV>  <DIV class=Section1>  <P class=MsoNormal><FONT face=Arial color=navy size=2><SPAN   style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">              Nick,</SPAN></FONT></P>  <P class=MsoNormal><FONT face=Arial color=navy size=2><SPAN   style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"></SPAN></FONT> </P>  <P class=MsoNormal><FONT face=Arial color=navy size=2><SPAN   style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">              Does your computer is on a network and/or have internet acces?  Window   Updated running  in the background with slow you down.</SPAN></FONT></P>  <P class=MsoNormal><FONT face=Arial color=navy size=2><SPAN   style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">              What is your Operating system?  With it happen on Xp and/or Win2000, the   I suggest you trying running on Win98 or vice versa.</SPAN></FONT></P>  <P class=MsoNormal><FONT face=Arial color=navy size=2><SPAN   style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"></SPAN></FONT> </P>  <P class=MsoNormal><FONT face=Arial color=navy size=2><SPAN   style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">              If you can trouble-shooting to Window version, it might give us some idea to   solve it.</SPAN></FONT></P>  <P class=MsoNormal><FONT face=Arial color=navy size=2><SPAN   style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"></SPAN></FONT> </P>  <P class=MsoNormal><FONT face=Arial color=navy size=2><SPAN   style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">              Han</SPAN></FONT></P>  <P class=MsoNormal><FONT face=Arial color=navy size=2><SPAN   style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"></SPAN></FONT> </P>  <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Tahoma size=2><SPAN   style="FONT-SIZE: 10pt; FONT-FAMILY: Tahoma">-----Original   Message-----<BR><B><SPAN style="FONT-WEIGHT: bold">From:</SPAN></B> Harwood,   Shaun [mailto:shaun.harwood@siemens.com] <BR><B><SPAN   style="FONT-WEIGHT: bold">Sent:</SPAN></B> Tuesday, April 05, 2005 9:03   AM<BR><B><SPAN style="FONT-WEIGHT: bold">To:</SPAN></B> VRF<BR><B><SPAN   style="FONT-WEIGHT: bold">Subject:</SPAN></B> RE: [vrf] Vee Pro 6.03 runtime   slowing down at midnight.</SPAN></FONT></P>  <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"   size=3><SPAN style="FONT-SIZE: 12pt"></SPAN></FONT> </P>  <DIV>  <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial color=blue   size=2><SPAN style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Arial">This   sounds similar to a problem reported by our operators about a month   ago.  Testset was testing away - close to midnight it slowed up - then it   hung.  They restarted the machine but it kept stopping during the   test.  The following morning we tested the product which we thought   had caused the problem, but it was fine.  This has happened several time   since.  Our IT people report no unusual activity on the network (no   backups/updates being run) during the night.  No answers I'm afraid -   don't know what causes it - but I guess I owe the operators an apology tonight   - I thought they were crazy.</SPAN></FONT></P></DIV>  <DIV>  <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"   size=3><SPAN style="FONT-SIZE: 12pt"></SPAN></FONT> </P></DIV>  <DIV>  <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial color=blue   size=2><SPAN style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Arial">Shaun   H</SPAN></FONT></P></DIV>  <BLOCKQUOTE style="MARGIN-TOP: 5pt; MARGIN-BOTTOM: 5pt">    <P class=MsoNormal     style="MARGIN-BOTTOM: 12pt; MARGIN-LEFT: 0.5in; MARGIN-RIGHT: 0in"><FONT     face=Tahoma size=2><SPAN     style="FONT-SIZE: 10pt; FONT-FAMILY: Tahoma">-----Original     Message-----<BR><B><SPAN style="FONT-WEIGHT: bold">From:</SPAN></B> Nick     Evans [mailto:nick@genesysibs.com]<BR><B><SPAN     style="FONT-WEIGHT: bold">Sent:</SPAN></B> Tuesday, April 05, 2005 8:19     AM<BR><B><SPAN style="FONT-WEIGHT: bold">To:</SPAN></B> VRF<BR><B><SPAN     style="FONT-WEIGHT: bold">Subject:</SPAN></B> RE: [vrf] Vee Pro 6.03 runtime     slowing down at midnight.</SPAN></FONT></P>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial color=blue     size=2><SPAN     style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Arial">Doesn't seem to     affect (or be caused by??)  any other programs.  Monitoring system     processes doesn't indicate any new process starting or any increase in     system idle processes, etc at the time of the slow down.   Vee is     consuming pretty much all of the system time at 90% or something     close.     Also, if you change the system time to 1 hour     later, it immediately cures the problem.   Could there be some bug     in the vee "timing related" functions like "on cycle", "delay",     etc????</SPAN></FONT></P>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"     size=3><SPAN style="FONT-SIZE: 12pt"></SPAN></FONT> </P>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial color=blue     size=2><SPAN style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Arial">If     anyone could confirm my findings it would be very useful to me as when I     first saw this I did think I was crazy!</SPAN></FONT></P>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"     size=3><SPAN style="FONT-SIZE: 12pt"></SPAN></FONT> </P>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial color=blue     size=2><SPAN     style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Arial">Nick</SPAN></FONT></P>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"     size=3><SPAN style="FONT-SIZE: 12pt"></SPAN></FONT> </P>    <DIV class=MsoNormal style="MARGIN-LEFT: 0.5in; TEXT-ALIGN: center"     align=center><FONT face="Times New Roman" size=3><SPAN     style="FONT-SIZE: 12pt">    <HR align=center width="100%" SIZE=2>    </SPAN></FONT></DIV>    <P class=MsoNormal     style="MARGIN-BOTTOM: 12pt; MARGIN-LEFT: 0.5in; MARGIN-RIGHT: 0in"><B><FONT     face=Tahoma size=2><SPAN     style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; FONT-FAMILY: Tahoma">From:</SPAN></FONT></B><FONT     face=Tahoma size=2><SPAN style="FONT-SIZE: 10pt; FONT-FAMILY: Tahoma">     Baranski, Detlef [mailto:Detlef.Baranski@pilkington.de] <BR><B><SPAN     style="FONT-WEIGHT: bold">Sent:</SPAN></B> 05 April 2005 09:31<BR><B><SPAN     style="FONT-WEIGHT: bold">To:</SPAN></B> 'Nick Evans'; VRF<BR><B><SPAN     style="FONT-WEIGHT: bold">Subject:</SPAN></B> AW: [vrf] Vee Pro 6.03 runtime     slowing down at midnight.</SPAN></FONT></P>    <DIV>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial color=blue     size=2><SPAN style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Arial">Is     this slowing down just belonging to VEE or also other     apps?</SPAN></FONT></P></DIV>    <DIV>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial color=blue     size=2><SPAN style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Arial">Can     you monitor it via "CPU-load" or similar?</SPAN></FONT></P></DIV>    <DIV>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial color=blue     size=2><SPAN     style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Arial">Sometimes windows     starts services like indexing or updating at certain times. Have a look in     your service manager.</SPAN></FONT></P></DIV>    <DIV>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial color=blue     size=2><SPAN style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Arial">But i     can not believe that this makes a just dramatic slowdown,...but everything     is possible in the PC-World.</SPAN></FONT></P></DIV>    <DIV>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial color=blue     size=2><SPAN style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Arial">Or is     it Harddisk-defragmentation ...or backup...or NSA     control...</SPAN></FONT></P></DIV>    <DIV>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"     size=3><SPAN style="FONT-SIZE: 12pt"></SPAN></FONT> </P></DIV>    <DIV>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial color=blue     size=2><SPAN     style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Arial">waiting to hear     your solution,</SPAN></FONT></P></DIV>    <DIV>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial color=blue     size=2><SPAN style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Arial">good     luck</SPAN></FONT></P></DIV>    <DIV>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial color=blue     size=2><SPAN     style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Arial">detlef</SPAN></FONT></P></DIV>    <DIV>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"     size=3><SPAN style="FONT-SIZE: 12pt"></SPAN></FONT> </P></DIV>    <BLOCKQUOTE style="MARGIN-TOP: 5pt; MARGIN-BOTTOM: 5pt">      <P class=MsoNormal       style="MARGIN-BOTTOM: 12pt; MARGIN-LEFT: 0.5in; MARGIN-RIGHT: 0in"><FONT       face=Tahoma size=2><SPAN       style="FONT-SIZE: 10pt; FONT-FAMILY: Tahoma">-----Ursprngliche       Nachricht-----<BR><B><SPAN style="FONT-WEIGHT: bold">Von:</SPAN></B> Nick       Evans [mailto:nick@genesysibs.com]<BR><B><SPAN       style="FONT-WEIGHT: bold">Gesendet:</SPAN></B> Dienstag, 5. April 2005       05:14<BR><B><SPAN style="FONT-WEIGHT: bold">An:</SPAN></B> VRF<BR><B><SPAN       style="FONT-WEIGHT: bold">Betreff:</SPAN></B> [vrf] Vee Pro 6.03 runtime       slowing down at midnight.</SPAN></FONT></P>      <DIV>      <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial       size=2><SPAN style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">Hi       All</SPAN></FONT></P></DIV>      <DIV>      <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"       size=3><SPAN style="FONT-SIZE: 12pt"></SPAN></FONT> </P></DIV>      <DIV>      <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial       size=2><SPAN style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">A customer has       just demonstrated a very strange problem to me.   We have a vee       6.03 programe running on a windows 2000 workstation under runtime.        It works fine unless the PC system time reaches midnight.  At this       point, the operation of the vee program slows to the point that it appears       to have hung up (it hasn't it is just working very, very       slowly).   The system remains like this as long as the system       time is somewhere within the midnight hour.  As soon as the time       reaches 1:00am or is set to a time other than the midnight hour, the       system recovers performance immediately.  I have not yet had       opportunity to try this with Vee 6.03 development so don't know if it is       limited to runtime.  Also, do not have the resources with me at the       moment to try vee 7.01 runtime.</SPAN></FONT></P></DIV>      <DIV>      <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"       size=3><SPAN style="FONT-SIZE: 12pt"></SPAN></FONT> </P></DIV>      <DIV>      <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial       size=2><SPAN style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">The vee program       in question is not constantly checking system time but does have some       delays and "on cycles" in it!   </SPAN></FONT></P></DIV>      <DIV>      <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"       size=3><SPAN style="FONT-SIZE: 12pt"></SPAN></FONT> </P></DIV>      <DIV>      <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial       size=2><SPAN style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">The problem is       not limited to this particular vee program or this PC.  Other vee       programs on this PC run the same way and the problem has also been       demonstrated on another PC.</SPAN></FONT></P></DIV>      <DIV>      <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"       size=3><SPAN style="FONT-SIZE: 12pt"></SPAN></FONT> </P></DIV>      <DIV>      <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial       size=2><SPAN style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">I am ashamed to       admit to my software engineering peers that I have obviously not been       burning the midnight oil whilst coding as I have never seen this problem       before.</SPAN></FONT></P></DIV>      <DIV>      <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"       size=3><SPAN style="FONT-SIZE: 12pt"></SPAN></FONT> </P></DIV>      <DIV>      <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial       size=2><SPAN style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">Does anyone have       any idea as to what may be causing this problem and what can be done to       fix it?</SPAN></FONT></P></DIV>      <DIV>      <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"       size=3><SPAN style="FONT-SIZE: 12pt"></SPAN></FONT> </P></DIV>      <DIV>      <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial       size=2><SPAN       style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">Thanks</SPAN></FONT></P></DIV>      <DIV>      <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"       size=3><SPAN style="FONT-SIZE: 12pt"></SPAN></FONT> </P></DIV>      <DIV>      <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face=Arial       size=2><SPAN       style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">Nick</SPAN></FONT></P></DIV></BLOCKQUOTE>    <P style="MARGIN-LEFT: 0.5in"><FONT face=Arial size=2><SPAN     style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">This message and any attachments     are confidential, for the exclusive use of the addressee and may be legally     privileged. Any other distribution, use or reproduction is unauthorised and     prohibited. If you have received this message in error, please notify the     sender immediately and delete the message from your system.     </SPAN></FONT></P>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"     size=3><SPAN style="FONT-SIZE: 12pt"></SPAN></FONT> </P>    <P style="MARGIN-LEFT: 0.5in"><FONT face=Arial size=2><SPAN     style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">Visit our internet site at     http://www.pilkington.com</SPAN></FONT></P>    <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"     size=3><SPAN style="FONT-SIZE: 12pt">---<BR>You are currently subscribed to     vrf as: shaun.harwood@siemens.com<BR>To subscribe send a blank email to     "join-vrf@it.lists.it.agilent.com".<BR>To unsubscribe send a blank email to     "leave-vrf@it.lists.it.agilent.com".<BR>To send messages to this mailing     list, email "vrf@agilent.com". <BR>If you need help with the mailing list     send a message to "owner-vrf@it.lists.it.agilent.com".   </SPAN></FONT></P></BLOCKQUOTE>  <P class=MsoNormal style="MARGIN-LEFT: 0.5in"><FONT face="Times New Roman"   size=3><SPAN style="FONT-SIZE: 12pt">---<BR>You are currently subscribed to   vrf as: tranh@tycoelectronics.com<BR>To subscribe send a blank email to   "join-vrf@it.lists.it.agilent.com".<BR>To unsubscribe send a blank email to   "leave-vrf@it.lists.it.agilent.com".<BR>To send messages to this mailing list,   email "vrf@agilent.com". <BR>If you need help with the mailing list send a   message to "owner-vrf@it.lists.it.agilent.com".   </SPAN></FONT></P></DIV>---<BR>You are currently subscribed to vrf as:   mazurro@kapl.gov<BR>To subscribe send a blank email to   "join-vrf@it.lists.it.agilent.com".<BR>To unsubscribe send a blank email to   "leave-vrf@it.lists.it.agilent.com".<BR>To send messages to this mailing list,   email "vrf@agilent.com". <BR>If you need help with the mailing list send a   message to "owner-vrf@it.lists.it.agilent.com". </BLOCKQUOTE>---<BR>You are currently subscribed to vrf as: rsb@soco.agilent.com<BR>To subscribe send a blank email to "join-vrf@it.lists.it.agilent.com".<BR>To unsubscribe send a blank email to "leave-vrf@it.lists.it.agilent.com".<BR>To send messages to this mailing list,  email "vrf@agilent.com".  <BR>If you need help with the mailing list send a message to "owner-vrf@it.lists.it.agilent.com".</BODY></HTML>  

Outcomes