AnsweredAssumed Answered

vrf Timing Problem with Init:Imm

Question asked by VRFuser on Aug 20, 2007
Latest reply on Aug 21, 2007 by VRFuser
I am trying to use VBA and GPIB commands, however I am having a problem with timing. I am first hitting Run SGL (single) and then "init:imm" and requesting Fetch EVM and reading it, however the timing for the init:imm takes 3 seconds for it to load and my program debugs. I tried the *WAI function after I placed the Init:Imm, however it did not work. I also tried the *OPC? command, however when I read in OpcOk$, it also came up as "1" and my evm value read in as "              ". (quotation with nothing in the middle). Any suggestions and comments other than putting in a manual delay. I want Rhode and Schwarz to tell me when the EVM value is ready to read, other than it reading in "          " (blank), if it is not ready for it to wait for it to be ready, and then read in the value.




Thanks

  _____  

Be a better Heartthrob. HYPERLINK "http://us.rd.yahoo.com/evt=48255/*http://answers.yahoo.com/dir/_ylc=X3oDMTI5MGx2aThyBF9TAzIxMTU1MDAzNTIEX3MDMzk2NTQ1MTAzBHNlYwNCQUJwaWxsYXJfTklfMzYwBHNsawNQcm9kdWN0X3F1ZXN0aW9uX3BhZ2U-?link=list&sid=396545433"Get better relationship answers from someone who knows.
Yahoo! Answers - Check it out. --- You are currently subscribed to vrf as: hua_jing@agilent.com To subscribe please send an email to: "vrf-request@lists.it.agilent.com" with the word subscribe in the message body. To unsubscribe send a blank email to "leave-vrf@it.lists.it.agilent.com". To send messages to this mailing list, email "vrf@agilent.com". If you need help with the mailing list send a message to "owner-vrf@it.lists.it.agilent.com". Search the "unofficial vrf archive" at "http://www.vrfarchive.com/vrf_archive". Search the Agilent vrf archive at "http://vee.engineering.agilent.com".  

Outcomes