AnsweredAssumed Answered

FW: vrf active X version (MS office)

Question asked by VRFuser on Jun 5, 2002
Latest reply on Jun 5, 2002 by VRFuser
Richard:

By checking off Excel 9.0 and Word 9.0 you are creating references to
function libraries (*.DLL?, *.OCX?).  Those function libraries are
not present if the user does not have MS Office 2000.

It would be possible to identify and locate those libraries and
forward them for installation on an Office 97 system but they
might not function properly and might get you in hot water with
the Microsoft lawyers.

It appears, my friend, that you are another victim of the upgrade
game.

Ted Jordan, P.E.
GE Nuclear Energy

-----Original Message-----
From: Richard Kleinhenz [mailto:scubaman@us.ibm.com]
Sent: Wednesday, June 05, 2002 8:17 AM
To: vrf@lvld.agilent.com
Subject: vrf active X version (MS office)


Hello,
I wrote an application on a machine that has MS Office 2000 installed.  I
use activeX automation to do some Word and some Excel stuff.  So, in device
- activeX automation, I have Excel 9.0 and Word 9.0 checked off.  I run Vee
6.03 under win2k.

Now I sent this app to a colleague.  He runs Vee 6.01 under nt4, and has
Office97 installed.  He can't run it!  He gets errors 'error loading
activeX components for Excel 9.0' and 'error loading activeX componenets
for Word 9.0' <sic>.  I am not doing anything complicated, and this happens
as the program starts up.  He has Excel 8.0 and Word 8.0 checked off in
device - activeX automation references.

Am I missing something obvious?  Previous versions of this program, before
I added Excel activeX, worked OK.  Now these errors, and I have not touched
the Word part in particular.  I have sent some simple test programs that
isolate the excel section the the colleague.  While they do ahve the
development environment, they are not experts at Vee, so telephone support
from here is laborious.  If anyone has any suggestions, please let me know.

One more thing:  The program also uses gravitybox's directory browser.  I
sent him the gbdirbrowse.ocx dated 5/2 which is the latest version, and he
installed it OK.  Again, there are similar problems getting that going.
Seems like half the activeX stuff is no good!  But, the old er version of
the program which just used Word activeX continues to work.  I already
resent the program, so it's not a corrupt file transmission.  Help!!!

--
Regards,
Rich
===========================
Richard Kleinhenz
mailto:scubaman@us.ibm.com
845-892-2617
===========================


---------------------------------------------------------------------
This is the "vrf" maillist, managed by Majordomo.  To send messages to
this maillist, just email to "vrf@lvld.agilent.com".  Subscriptions and
unsubscriptions are done through the address "vrf-request@lvld.agilent.com".
If you need details, just send a message containing the text "help"
to "vrf-request@lvld.agilent.com".
---------------------------------------------------------------------
---------------------------------------------------------------------
This is the "vrf" maillist, managed by Majordomo.  To send messages to
this maillist, just email to "vrf@lvld.agilent.com".  Subscriptions and
unsubscriptions are done through the address "vrf-request@lvld.agilent.com".
If you need details, just send a message containing the text "help"
to "vrf-request@lvld.agilent.com".
---------------------------------------------------------------------

Outcomes