AnsweredAssumed Answered

vrf HP 5347A with XP and USB

Question asked by VRFuser on Jan 17, 2003
Seppo,

Kathy's right. Especially after a reset (*RST) of the instrument.
I found with the older 435 power meters the same problem exists.
Add at least a 1 or 2 second delay before the commands that fail
to work correctly. If it starts to work as expected, then you can
work at reducing or eliminating delays to see where the sensitive
areas are that have to have them left in.

Mike Groves

-----Original Message-----
From: Kathy Kiessling [mailto:k.kiessling@attbi.com]
Sent: Friday, January 17, 2003 7:23 AM
To: VEE vrf
Subject: [vrf] Re: HP 5347A with XP and USB


I've seen similar problems several times when upgrading computers, where the
new computer was much faster than the old one.  Adding delays was a quick
cure.

-- Kathy Kiessling

----- Original Message -----
From: "Seppo Metsl" <seppo.metsala@mil.fi>
To: "VEE vrf" <vrf@it.lists.it.agilent.com>
Sent: Thursday, January 16, 2003 11:47 PM
Subject: [vrf] HP 5347A with XP and USB


Hi All

I have a tester which have a HP 5347A Microwave counter / Power meter. Test
software has been working on HP-UX and HP VEE 4 for many years. Now we have
moved the .vee software to PC which uses MS XP Pro and VEE Pro. Buses (3)
use USB-GPIB Interfaces and VISA version is L.02.

The problem is that the 5347 does not go to power meter mode on command
"lg". Also command "ze" does't work. It stays on counter mode. Instrument
seems to be OK because we tried with another unit.

If I use VISA assistant it finds a lot instruments which are not present.
Seems like the instrument responds to every address, even subaddresses.
When only 5347 connected to bus there might be 35 instruments found in
different addresses. Oddly sometimes it finds only 1 instrument and when
multiple instruments found, addresses change. The same behaviour is on VEE
Find Instrument function.

When tried with a different instrument like TEK 2430 it finds every time
only one instance.

We tried using laptop with WIN 98 and Ines PCMCIA GPIB card and even though
it also found sometimes several "dummy" instruments the commands "lg", "ze"
and "auto" worked fine.

Is there any possibility that power meter as being so old doesn't comform
IEEE488 standards and responses to every command sended to bus?

Any help greatly appreciated

Seppo Metsl
seppo.metsala@mil.fi

Test Automation Engineering and Support
Electronics Centre


---
You are currently subscribed to vrf as: rsb@soco.agilent.com
To subscribe send a blank email to "join-vrf@it.lists.it.agilent.com".
To unsubscribe send a blank email to "leave-vrf@it.lists.it.agilent.com".
To send messages to this mailing list,  email "vrf@it.lists.it.agilent.com". 
If you need help with the mailing list send a message to "owner-vrf@it.lists.it.agilent.com".

Outcomes