AnsweredAssumed Answered

vrf MS Access problem

Question asked by VRFuser on Mar 26, 2003

Hi Mike,
      Thanks for the offer, but have solved my little problem.

The problem was due to our MIS department define a new workgroup
administrator file. (.mdw).
This caused a problem as it assigned security levels.
To access the database, the following code was used.

resultsTable (Declared) Recordset.
mdb (Declared) Database.
DBENG (Declared) DBEngine.

SET DBENG=createObject("DAO.DBEngine.35");
DBENG.SYSTEMDB="\\ntsrv1\common\dbfiles\system\example.mdw";
DBENG.systemdb;
DBENG.createworkspace("","admin","xxx",DBUSEJET);
Set mdb = DBENG.WORKSPACES(0).OpenDatabase(mdbFileSpec,False , False);
Set resultsTable = mdb.OpenRecordSet("qEnduranceTestData",dbOpenDynaset)

Maybe this will help somebody one day!

Regards

Gavin Candy.

Quality Engineer.
BHC Components Ltd
20-21 Cumberland Drive
Granby Industrial Estate
Weymouth
DT4 9TE
England

Tel:         ++44  1305 830734
Fax:        ++44  1305 760670
Email:      gavin.candy@bhc.co.uk
website:    http://www.bhc.co.uk







                      M Watts
                      <MikeJWatts@compu        To:       "INTERNET:gavin.candy@bhc.co.uk" <gavin.candy@bhc.co.uk>
                      serve.com>               cc:       "VEE vrf" <vrf@it.lists.it.agilent.com>
                                               Subject:  [vrf] MS Access problem
                      26/03/03 15:51






Hi Gavin,
         Thanks for checking out my website - and for your comments.

I tried a few ideas based on your e-mail but, assuming there is a database
file at c:EnduranceTest.mdb, there is a table called TestDetails and that
you have exclusive rights to the database and table ( i.e. that you can
open them without having to give access to others ) I'm not sure what the
problem is.  If you want to mail me an example ( suitably 'sanitised' such
that there is no sensitive data ) I'd be happy to have a quick look to see
if I can replicate the problem you see.


Mike Watts





---
You are currently subscribed to vrf as: rsb@soco.agilent.com
To subscribe send a blank email to "join-vrf@it.lists.it.agilent.com".
To unsubscribe send a blank email to "leave-vrf@it.lists.it.agilent.com".
To send messages to this mailing list,  email "vrf@it.lists.it.agilent.com". 
If you need help with the mailing list send a message to "owner-vrf@it.lists.it.agilent.com".

Outcomes