AnsweredAssumed Answered

vrf FW: vrf E-Cal error on the 8753ES

Question asked by Dr_joel Employee on Sep 2, 2003
Hello Rick..
     Interesting behavior.  (or is it behaviour?).  I opened your set-up
box and I did notice one thing.  I see that you put the mode into continous,
then change to channel two, opc the change, do some more stuff, then start ecal.

I think I've seen problems changing channels with the OPC, where the opc returns
before the channel change is really done (this is especially true in hold mode).
-Yeah, yeah, OPC is supposed to really be complete before it returns, but, I think
it has to do with some start of sweep setup that is only done when we get a sweep trigger
command (sing, cont).  So, in my programming, after I get everything set-up, I send an OPC?SING.
I know that this is a very robust way to ensure that everything is setup, and ready for the
next triggered sweep.  Otherwise, I find that sometimes the behavior is slightly different
for the first "sing" after setup.

As far as the 8753E vs 8753ES, boy, you have me there.  I've looked in the source code, and
there are a couple of compile time switches between the two, but they are very, very close
to the same code. (The main difference is dealing with the 4 channel buttons instead of 2 channel
buttons), but maybe the updating of the 4 buttons (and additional lights) added something that
messes up ECAL.  Still... can't really explain it.

With respect to ecal: the orientation is the first thing ECAL does, and to do this, the ecal code
takes control of the channel, and changes to CW, 3 points, then takes several quick ECAL state readings
to see if the ecal is connected (it looks for changes in the S-parameters and does some math to decide
where it must be connected).  The ecal code looks for a specific difference between, say, S11 of the open
state and S11 of the short.  Two much loss makes the difference to small.  (We changed the value lower
when we added ecal to the firmware, the stand-alone PC version is much more sensitive to this problem).
Since it takes control, if the other changes to channel haven't caught up, maybe that's where ecal gets
messed up. I think the channel changes might tromp on the ecal control, maybe exacerbated by using list mode.

By the way, it does my heart good to see someone using the segmented power settings. We put all these fancy
features in, and wonder if anyone ever finds them.

Joel
-----Original Message-----
From: Rick Hart [mailto:rhart@suptech.com]
Sent: Friday, August 29, 2003 3:37 PM
To: VEE vrf
Subject: [vrf] FW: vrf E-Cal error on the 8753ES


Joe,
I was able to troubleshoot this down a bit further and found out a few
things....
By the way I'm using:
An 8753ES with firmware revision 7.74.
An E-Cal P/N 85092-60010 (N-Type, 300k to 9 GHz).

The E-Cal works fine without the "ECal MODULE NOT IN RF PATH" error until I
try to set up an instrument state from scratch and then run the automated
E-Cal routine (see attached file). I can then get the whole thing to work
only if I put a delay of at least 7 seconds between the "ECALFUL2" & the
"ECALDONE" commands, otherwise it fails every time.
Rick


-----Original Message-----
From: joel_dunsmore@agilent.com [mailto:joel_dunsmore@agilent.com]
Sent: Thursday, August 28, 2003 6:40 PM
To: rhart@suptech.com; vrf@it.lists.it.agilent.com
Subject: RE: [vrf] vrf E-Cal error on the 8753ES


Hello Rick,
     I ran this on my 8722ES using an RF ECAL, 50MHz-3GHz.  Worked fine.

I have seen some problems if there is too much loss from the 8753ES test
port to the ECAL connection.
The failure is usually in what we call "orientation".  I can't say why it
should be different remotely
than from the front panel.  I haven't seen this reported before as a defect.
Which ECAL and what firmware
rev are you on? (My 8722 was rev 7.70).

One -probably not related- thing to try is to turn cal off before starting
an Ecal. I've seen it reported
that ECAL reports "no-module in path" intermittantly if ECAL is done with
CAL on, but I can't verify that
it's a problem with my 8722. (Tried both ways, every thing still works
fine). Other things to try is to
put the '53 in hold mode first (maybe some weird timing?). Don't know.

Best Regards, Joel
-----Original Message-----
From: Rick Hart [mailto:rhart@suptech.com]
Sent: Thursday, August 28, 2003 5:56 PM
To: VEE vrf
Subject: [vrf] vrf E-Cal error on the 8753ES


Hello,
I've come up with an issue having to do with the E-Cal & the 8753ES. I'm
getting the following error even when the E-Cal module IS connected during a
calibration.......
ECal MODULE NOT IN RF PATH
It then does not finish the calibration (but also will not lock up the
Analyzer).
This appears to be happening only when sending the automated commands to
perform an E-Cal as when I try to calibrate manually through the Analyzer's
front panel it never happens. I have example code attached. If anyone can
tell me what I'm doing wrong or maybe it's a bug in the 8753 firmware?
By the way I appreciate Agilent's direction in allowing E-Cal to be
implimented on the 8753, it is a real time saver and I'm getting positive
feed-back from the Tech's who are now using it.
Thank You,

Rick Hart

Superconductor Technologies Inc.

<<ECal.vee>>


---
You are currently subscribed to vrf as: rsb@soco.agilent.com
To subscribe send a blank email to "join-vrf@it.lists.it.agilent.com".
To unsubscribe send a blank email to "leave-vrf@it.lists.it.agilent.com".
To send messages to this mailing list,  email "vrf@it.lists.it.agilent.com". 
If you need help with the mailing list send a message to "owner-vrf@it.lists.it.agilent.com".

Outcomes