AnsweredAssumed Answered

vrf AW: Strange problem with Excel & VEE

Question asked by bernhardt on Nov 24, 2003
Hi Tom,

in a past project I had a problem with using functions from add-ins from
EXCEL.
The solution was to deactivate the add-in and then activate it again.

xlApp.AddIns("analysis toolpak").Installed = FALSE;
xlApp.AddIns("analysis toolpak - vba").Installed =FALSE;
xlApp.AddIns("analysis toolpak").Installed = TRUE;
xlApp.AddIns("analysis toolpak - vba").Installed = TRUE;

I reported this problem to Microsoft and they had the same behaviour.
In any case you should deactivate the alerts like Mark told you.

Best regards
M. Bernhardt
---------------------------------------------
SOMATEC - Software fr Maschinensteuerungen
und Automatisierungstechnik GbR

Jagdweg 7a
D-82041 Deisenhofen

Telefon :  (089) 613 984 94
Fax :      (089) 613 981 23
Email :    Bernhardt@somatec.de
homepage : www.somatec.com
---------------------------------------------


-----Ursprngliche Nachricht-----
Von:      Goldberg, Mark [mailto:Mark.Goldberg@ATK.COM]
Gesendet:     Freitag, 21. November 2003 16:09
An:     VRF
Betreff:     [vrf] RE: Strange problem with Excel & VEE

Tom,

Not sure how to do what you were asking for, but you might try:

ExcelApp.DisplayAlerts =FALSE;

If I remember correctly this prevents messages from being displayed. Just
make sure you are taking of any errors programmatically or you could run
into trouble.

Mark

-----Original Message-----
From: Thomas.Mitchell@Autoliv.com [mailto:Thomas.Mitchell@Autoliv.com]
Sent: Friday, November 21, 2003 4:31 AM
To: VRF
Subject: [vrf] Strange problem with Excel & VEE


I have a strange problem that really has me stumped.  I have a test program
that I first started working on about 5-6 years ago.  This program has
really evolved over the years.  I started out using DDE with Excel, and now
I'm starting to rewrite some of the user function using ActiveX.  As part
of my test program, I extract an S-Record from an imbedded micro on one of
our modules.  This data is then loaded into a different Excel spreadsheet,
and there are macros that run and convert some of the hex data to decimal,
and it also decodes some of the data bytes in to a format that is easily
understandable by the user.

Now my problem.  When one of my co-workers gave me this Excel tool (also
evolving, original roots back to Excel 4.0?), we tried to load my input
data file, and the conversion didn't work properly.  He then went and
checked my add-in's in Excel, and noticed that I didn't have a box checked.
We checked the box, then it asked for the install disk to load that
feature.  We loaded the feature, and my Excel tool functions properly, but
now I get a strange message from Excel (see attached) (See attached file:
excel_error.bmp) asking me if I want to replace resume.xlw.  I had never
seen this before.  This causes my VEE program to hang because it is looking
for a YES or NO answer.  Can I tell it via ActiveX YES or NO?  If so, how
do I do it?  excelApp.YES()?

Thanks,

Tom Mitchell
Autoliv AEA

---
You are currently subscribed to vrf as: Bernhardt@somatec.de
To subscribe send a blank email to "join-vrf@it.lists.it.agilent.com".
To unsubscribe send a blank email to "leave-vrf@it.lists.it.agilent.com".
To send messages to this mailing list,  email "vrf@agilent.com". 
If you need help with the mailing list send a message to
"owner-vrf@it.lists.it.agilent.com".

---
You are currently subscribed to vrf as: rsb@soco.agilent.com
To subscribe send a blank email to "join-vrf@it.lists.it.agilent.com".
To unsubscribe send a blank email to "leave-vrf@it.lists.it.agilent.com".
To send messages to this mailing list,  email "vrf@agilent.com". 
If you need help with the mailing list send a message to "owner-vrf@it.lists.it.agilent.com".

Outcomes