AnsweredAssumed Answered

vrf 8510 panel driver

Question asked by VRFuser on Nov 14, 2004
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"><HTML><HEAD><META http-equiv=Content-Type content="text/html; charset=us-ascii"><META content="MSHTML 6.00.2900.2523" name=GENERATOR></HEAD><BODY><DIV dir=ltr align=left><SPAN class=955443115-15112004><FONT face=Arial color=#0000ff size=2>Ok, I see.  I had a similar problem a few years back and the way I solved it was to simply replace the GPIB, the 82350, but I had a new PC.  But now I am not sure, it might be your machine as well as the card.  I'm assuming your "syntax and data" worked before, so in fact is ok.  Hence, the only thing I can think of is the instrument driver and the GPIO as well as the computer.</FONT></SPAN></DIV><DIV dir=ltr align=left><SPAN class=955443115-15112004><FONT face=Arial color=#0000ff size=2></FONT></SPAN> </DIV><DIV dir=ltr align=left><SPAN class=955443115-15112004><FONT face=Arial color=#0000ff size=2>So here is my reasoning.  The old driver and the old PC are happy together.  The new VEE requires new drivers.  Hence, suspect you'll also need to update you GPIO as well as your PC.  Else revert to the older versions. </FONT></SPAN></DIV><DIV dir=ltr align=left><SPAN class=955443115-15112004><FONT face=Arial color=#0000ff size=2></FONT></SPAN> </DIV><DIV dir=ltr align=left><SPAN class=955443115-15112004><FONT face=Arial color=#0000ff size=2></FONT></SPAN> </DIV><DIV dir=ltr align=left><SPAN class=955443115-15112004><FONT face=Arial color=#0000ff size=2>rufus</FONT></SPAN></DIV><BR><DIV class=OutlookMessageHeader lang=en-us dir=ltr align=left><HR tabIndex=-1><FONT face=Tahoma size=2><B>From:</B> Hejsek Frantisek [mailto:fhejsek@cmi.cz] <BR><B>Sent:</B> Monday, November 15, 2004 4:10 AM<BR><B>To:</B> Rufus Warren; VRF<BR><B>Subject:</B> RE: [vrf] 8510 panel driver<BR></FONT><BR></DIV><DIV></DIV><DIV dir=ltr align=left><FONT face=Arial size=2><SPAN class=042570615-11112004></SPAN></FONT><FONT face=Arial color=#0000ff size=2><SPAN class=042570615-11112004>Hi Rufus,</SPAN></FONT></DIV><DIV dir=ltr align=left><FONT face=Arial color=#0000ff size=2><SPAN class=042570615-11112004></SPAN></FONT> </DIV><DIV dir=ltr align=left><FONT face=Arial color=#0000ff size=2><SPAN class=042570615-11112004>Approx two years or so. It was the last model (at that time) with PCI bus and one ISA slot (used for the GPIB Card). When operating under NT there were no problems and under W2k now I can see no substantial delay. The selection of interrupt and I/O address had to be done with care, but it was expected. Agilent compatibility matrix says the card should operate under W2k.</SPAN></FONT></DIV><DIV dir=ltr align=left><FONT face=Arial color=#0000ff size=2><SPAN class=042570615-11112004>The behavior of the 8510c7 panel driver in VEE 6.2 and 7.0 is slightly different (in VEE7 it doesn't display the trace) and I thought that there may a room for some simple error.</SPAN></FONT></DIV><DIV dir=ltr align=left><FONT face=Arial color=#0000ff size=2><SPAN class=042570615-11112004></SPAN></FONT> </DIV><DIV dir=ltr align=left><FONT face=Arial color=#0000ff size=2><SPAN class=042570615-11112004>Best Regards,</SPAN></FONT></DIV><DIV dir=ltr align=left><FONT face=Arial color=#0000ff size=2><SPAN class=042570615-11112004>Frantisek </SPAN></FONT></DIV><BR><BLOCKQUOTE style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #0000ff 2px solid; MARGIN-RIGHT: 0px">  <DIV class=OutlookMessageHeader lang=cs dir=ltr align=left>  <HR tabIndex=-1>  <FONT face=Tahoma size=2><B>From:</B> Rufus Warren [mailto:rwarren@amti.net]   <BR><B>Sent:</B> Thursday, November 11, 2004 2:12 PM<BR><B>To:</B> Hejsek   Frantisek; 'VRF'<BR><B>Subject:</B> RE: [vrf] 8510 panel   driver<BR></FONT><BR></DIV>  <DIV></DIV>  <DIV dir=ltr align=left><SPAN class=441490713-11112004><FONT face=Arial   color=#0000ff size=2>How old is your PC?  Surely you do not have an ISA   buss, do you?  Your answer may not exist with the stipulations you   request.   You will need an 82350 PCI GPIB and a PC with a PCI   buss.</FONT></SPAN></DIV>  <DIV dir=ltr align=left><SPAN class=441490713-11112004><FONT face=Arial   color=#0000ff size=2></FONT></SPAN> </DIV>  <DIV dir=ltr align=left><SPAN class=441490713-11112004><FONT face=Arial   color=#0000ff size=2></FONT></SPAN> </DIV>  <DIV dir=ltr align=left><SPAN class=441490713-11112004><FONT face=Arial   color=#0000ff size=2>How did you get 2000 to run on an ISA buss?  Isn't   it too slow?</FONT></SPAN></DIV>  <DIV dir=ltr align=left><SPAN class=441490713-11112004><FONT face=Arial   color=#0000ff size=2></FONT></SPAN> </DIV>  <DIV dir=ltr align=left><SPAN class=441490713-11112004><FONT face=Arial   color=#0000ff size=2></FONT></SPAN> </DIV>  <DIV dir=ltr align=left><SPAN class=441490713-11112004><FONT face=Arial   color=#0000ff size=2>rufus</FONT></SPAN></DIV><BR>  <DIV class=OutlookMessageHeader lang=en-us dir=ltr align=left>  <HR tabIndex=-1>  <FONT face=Tahoma size=2><B>From:</B> Hejsek Frantisek [mailto:fhejsek@cmi.cz]   <BR><B>Sent:</B> Thursday, November 11, 2004 6:42 AM<BR><B>To:</B>   VRF<BR><B>Subject:</B> [vrf] 8510 panel driver<BR></FONT><BR></DIV>  <DIV></DIV>  <DIV><FONT face=Arial size=2><SPAN class=577213409-11112004>Hello   Vrf,</SPAN></FONT></DIV>  <DIV><FONT face=Arial size=2><SPAN   class=577213409-11112004></SPAN></FONT> </DIV>  <DIV><FONT face=Arial size=2><SPAN class=577213409-11112004>I have a problem   with 82341A ISA GPIB Card + W2k machine. I know this card, depending on   its version can have a problem with W2k. The error  appears only   with 8510 Panel Driver and error message is "Instrument driver error   1077: Insufficient data for Enter in device |devName>, line 8430. Error   number 810." The error doesn't depend on VEE version (6.2, 7). The I/O lib is   M.01.01.04 (patched).  I am not sure (my mistake) but I think the problem   have appeared when I switched from NT to W2k. The 82357A USB/GPIB interface   seems to operate correctly on that machine. The program I am   using works fine for years.</SPAN></FONT></DIV>  <DIV><FONT face=Arial size=2><SPAN class=577213409-11112004>I appreciate any   idea (except to discard the card or panel driver, which is mine).   Thanks.</SPAN></FONT></DIV>  <DIV><FONT face=Arial size=2><SPAN   class=577213409-11112004></SPAN></FONT> </DIV>  <DIV><FONT face=Arial size=2><SPAN class=577213409-11112004>Best   Regards,</SPAN></FONT></DIV>  <DIV><FONT face=Arial size=2><SPAN   class=577213409-11112004>Frantisek</SPAN></FONT></DIV>  <DIV><FONT face=Arial size=2><SPAN   class=577213409-11112004></SPAN></FONT> </DIV>  <DIV><!-- Converted from text/plain format --><FONT size=2>  <P align=left><FONT face=Tahoma   size=1>--------------------------------------------------------------------------<BR>Frantisek   Hejsek<BR>Microwave Measurement Laboratory (1013)<BR>Czech Metrology   Institute<BR>Radiova 3, 102 00 Praha 10, Czech Republic<BR>E-mail:     fhejsek@cmi.cz<BR>Tel:    +(420) 266 020 172,     Fax:  +(420) 272 704   852<BR>-------------------------------------------------------------------------<BR></FONT></P></FONT></DIV>---<BR>You   are currently subscribed to vrf as: rwarren@amti.net<BR>To subscribe send a   blank email to "join-vrf@it.lists.it.agilent.com".<BR>To unsubscribe send a   blank email to "leave-vrf@it.lists.it.agilent.com".<BR>To send messages to   this mailing list, email "vrf@agilent.com". <BR>If you need help with the   mailing list send a message to "owner-vrf@it.lists.it.agilent.com". </BLOCKQUOTE>---<BR>You are currently subscribed to vrf as: rsb@soco.agilent.com<BR>To subscribe send a blank email to "join-vrf@it.lists.it.agilent.com".<BR>To unsubscribe send a blank email to "leave-vrf@it.lists.it.agilent.com".<BR>To send messages to this mailing list,  email "vrf@agilent.com".  <BR>If you need help with the mailing list send a message to "owner-vrf@it.lists.it.agilent.com".</BODY></HTML>  

Outcomes