AnsweredAssumed Answered

VEE Configuration and VEE accuracy

Question asked by VRFuser on Jul 11, 1996
from: Juan Carlos Martin / INDRA ESPACIO
      jcmar@mdr.inisel-espacio.es / 34-1-3963995 / FAX 34-1-3963912
      INDRA ESPACIO
to:   hpvxd_xc@hpislsup.lvld.hp.com
date: Thursday, 11 July 1996


Hello everybody,

a) I'm working with the following HW/SW configuration:

  SW
- VEE V3.12
- Windows V3.11 (and windows NT)
- MS-DOS V6.22
  HW
- PENTIUM 100
- 32 MB of RAM
- In some cases NFS (tool to access files from diferent network users)

I think that my applications run too slowly, maybe due to my memory
configuration. I would like to know which is the better SW memory
configuration for VEE.

b) On the other hand, I have the following silly VEE program:

         .--------.                                         .-----------.
         | Start  |                                         | Display 1 |
         '--------'                                         +-----------+
             |                         +------------------->|   -0.9    |
             v                         |                    '-----------'
     .---------------.     .--------.  |  .------------.    .-----------.
     | Real Constant |     | Formula|  |  |   If/else  |    | Display 2 |
     +---------------+     +--------+  |  +------------+    +-----------+
     |     -9.9      |---->| frac(x)|--+->|If -0.9<x=<0|--->|    ---    |
     '---------------'     '--------'     +------------+    '-----------'
                                          | else       |-+  .-----------.
                                          '------------' |  | Display 3 |
                                                         |  +-----------+
                                                         +->|     0     |
                                                            '-----------'   

It seems that VEE data flow should go to display 2, but it isn't. Moreover,
if connect line between formula and display 1 objects is checked, -0.9 value
is shown. I though that the problem could be in the numer properties of the
display 1 object. I changed that properties to obtain a fixed real number of
32 digits: I got the same.
Then I modified the general application properties of the main menu and I
got the same. But when I checked the line I got -0.90.....04. That means VEE
works with many digits but only shows a few. The above is a silly problem
but this kind of calculations can be complicated if they are done in the
middle of a more complicated structure and we need a certain accuracy.
Of course, that making comparations of real numbers isn't a good policy but
VEE could have a object to round the decimal numbers to be used for one
specific object.
I would like to know more information about the accuracy in which VEE works.
May anybody knows more about it?

Thanks, J.C.


Outcomes