AnsweredAssumed Answered

vrf File Path Problem with To/From File - error 630 - Resolved

Question asked by tdllc01 on Dec 5, 2001
Hi Shawn,

I loaded the program onto an ancient P133 with NT4.0 and VEE  5.01.    That
platform demonstrated the file problem, which allowed me to do the
diagnostics locally.

The data file path is generated by reading an initial value out of an
administration file and then computing the final resultant file path + name
in a carefully controlled thread.

The initial file path contained a leading space, which was difficult to see
with the line probe, but sufficient to cause a huge anomaly in the operation
of the To/From File box.  A simple "strTrim" fixed the problem.

I'm still certain it is timing related since the P500 SCSI based development
system did not demonstrate the problem, but the P133 IDE system did have a
problem.  The target platform is also IDE based, with a P266.

Hopefully, when I load the fixed version onto the target platform tomorrow,
it will behave as designed.

Thanks for all of your assistance.

-George-


> Hi again.
>
> >I do force firing of the input
> >pin first with the sequence in/out.
>
> In that case, I do believe you have a bonafied mystery on your hands. I do
> have another suggestion, but it really should be taken with a grain of
salt.
>
> Back in the 3.12 & 4 days, every once-in-a-while a program would totally
> screw up during development. Using the trace facility, I would watch as an
> entire function or section of a function would execute with no reguard for
> constraints, data flow or even logic. VEE would hop around, executing
> objects seemingly at random.
>
> The program would look fine on the screen, but obviously something in the
> text file that constitutes a VEE program was making VEE wack-o.
>
> I never did figure out exactly what the problem was because it was never
> reliably reproducable. The solution, however, was to delete the affected
> function or section of code, save the program, exit VEE, restart VEE,
reload
> the program and reconstruct what was deleted. It worked every time.
>
> Looking back through my logs I see this hasn't happened since we started
> using VEE 5. I certainly hope you can figure out what's going on in your
> case.
> -SHAWN-
>
>
>
> _________________________________________________________________
> Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp
>
> ---------------------------------------------------------------------
> This is the "vrf" maillist, managed by Majordomo.  To send messages to
> this maillist, just email to "vrf@lvld.agilent.com".  Subscriptions and
> unsubscriptions are done through the address
"vrf-request@lvld.agilent.com".
> If you need details, just send a message containing the text "help"
> to "vrf-request@lvld.agilent.com".
> ---------------------------------------------------------------------

---------------------------------------------------------------------
This is the "vrf" maillist, managed by Majordomo.  To send messages to
this maillist, just email to "vrf@lvld.agilent.com".  Subscriptions and
unsubscriptions are done through the address "vrf-request@lvld.agilent.com".
If you need details, just send a message containing the text "help"
to "vrf-request@lvld.agilent.com".
---------------------------------------------------------------------

Outcomes