AnsweredAssumed Answered

VRf - Compatibility problem!

Question asked by VRFuser on Apr 25, 1999
Latest reply on Apr 25, 1999 by VRFuser
Hi all,

I also investigated this strange model of my colleagues. This model is
not loadable by neither HP VEE 3.1 nor HP VEE 4.0 under HP-UX. However
when loading it into HP VEE 3.2 the serious error message "detailView
and detailViewInfo both exist." appeared when I want to edit a
UserObject. When viewing this VEE model in ASCII it seems that it is
neither 3.1 format nor 3.2 format. My question now is: Could it be that
the model was affected by opening, editing and saving it on a PC version
of HP VEE ? Does anyone have bad experiences with the compatibility of
VEE models between PC and HP-UX versions of VEE ??

Kind regards,
Arjen Bakker

--
  P.A. Bakker
  Philips Research Laboratories

  P.O. Box WAY-41            Phone : +31 40 2743728
  Prof. Holstlaan 4          Fax   : +31 40 2744657
  5656 AA Eindhoven         
  The Netherlands            mailto:bakkera@natlab.research.philips.com

3.1 format:
----------

#! /usr/lib/veetest/veetest -r
(revision "1.2")
(date "Wed 04/Oct/1995")
(component 0 "ROOTCONTEXT"
(implementation
  (component 0 "CONTEXT"


3.2 format:
----------

(saveFormat "2.0")
(date "Thu 08/Apr/1999 11:18:09 METDST")
(veerev "3.2")
(platform "HP9000s700")
(SaveCF no)
(filterNAN 0)
(component 0 ROOTCONTEXT

Philips Nijmegen model:
-----------------------
#! /usr/lib/veetest/veetest -r
(saveFormat "1.2")
(date "Wed 24/Feb/1999")
(SaveCF no)
(filterNAN 0)
(component 0 ROOTCONTEXT


geert van raaij wrote:
>
> Dear VEE-users (and HP of course),
>
> we, at Philips Semiconductors The Netherlands, used VEE v3.12.
> Operating system was Unix 9.xx. Last month we upgraded to VEE v3.21
> under Unix 10.20. Now we have a biiiig problem when opening and/or
> modifying the old VEE v3.12 file within the new VEE 3.21 environment.
>
> At some UserObjects errors occur when trying to open the detailView.
> Opening the same UserObject to PanelView is no problem at all.
> When trying to open the DetailView following message occurs:
>
>    Caution:
>    Specified active view (unknown) is not present.
>
> After this message I tried to open the DetailView of the UserObject
> Following RED error message occured:
>
>    Serious Error!
>    Internal Error: detailView and detailViewInfo both exist .....
>    Error Number 999
>
> .... the UserObject opened and I noticed that all the connection
> lines between the objects disappeared!! And you're not able to
> connect them again!
>
> I tried all of this also using VEE v5.0; this resulted in (almost)
> the same errors.
>
> I thought vee files were upwards-compatible!
> Can someone help us out here?!
>
> thanks in advance,
>
> Geert van Raaij
> Product Engineer Digital Audio group
> Philips Semiconductors Nijmegen
> The Netherlands

Outcomes