AnsweredAssumed Answered

VRF-UserObjects

Question asked by VRFuser on Aug 13, 1996
send q VRF-UserObjects vrf ww marco@gore.afep.cornell.edu ww

from: Greg Goebel / HP-MXD
      gvg@lvld.hp.com / 970-679-3030 / FAX 970-679-5971
to:   Marco Panzella / VRf
date: Wednesday, 14 August 1996 1153 MDT

Marco:  Everybody's probably about ready to lynch me for belaboring this so
much ... but you might put a text header with your name and address in the text
of your message (like the one above).  Lots of odd and unexpected things can
happen to email out there in the wilds of the Internet and it can help
ensure you a better and faster response.

> Hello.
>
> I have a VEE program that has a 2 level userobject.  That is...a user object
> within a userobject.  I have data in the lower level that I want to graph
> with the X-Y plot object.  This X-Y plot object will be placed in panel view.
> Therefore I have the plot objects on the top level and bring the data out
> from the 2-deep level to the top.
>
> Problem:  It doesn't graph.  If I put the X-Y plot in the first userobject,
> ie.  one level deep, then it does plot.  Does anyone have an idea to this?  I
> have the X-Y plot object on the top panel for two reasons:  (1) to avoid main
> sub-panels and thus decrease confussion, and (2) I need to be able to share
> the X-Y plots by a couple sections of my program.  In other words, I have
> different tests that needs to plot to the same graph, and also I have a "view
> data file" that needs to output to the same graph.

Some comments:

% I built a UserObject with an XY Trace object and an OK button and put
   then on the Panel View for the User Object.  I wired the Sequence out
   pin of the UserObject to its Auto Scale input pin, and to the OK button.
   I configured the UserObject to "Show Panel On Execute".

   When I fired a cosine wave into this UserObject from a Function Generator,
   the panel popped up and displayed the cosine wave until I clicked on the
   OK button to make it go away.

% Next, I put the UserObject inside another UserObject and tried the same
   experiment.  It worked OK.

   Is there some simple example you can show us to give some idea of what
   you are doing?

% Also, could you clarify your intent a little?  Are you trying to simply
   build one UserObject and clone it several times?

> Any sudgestions?  Thank you in advance!  Marco.

Please stay in touch.

[<>] regards -- gvg

Outcomes