AnsweredAssumed Answered

vrf File Path Problem with To/From File - error 630

Question asked by VRFuser on Dec 5, 2001
In a case like that, I would try to make a new "To File" or "From File"
object to see if it works.  Sometimes I have strange problems like this,
where something that worked before just stop working.  I found in most
occasions that it is due to a "defective component".  I just replace the
defective object with a new one and every thing works as new.

Bruno.

-----Message d'origine-----
De: Shawn Fessenden [mailto:s_fessenden@hotmail.com]
Date: 5 dcembre 2001 15:31

>I do force firing of the input
>pin first with the sequence in/out.

In that case, I do believe you have a bonafied mystery on your hands. I do
have another suggestion, but it really should be taken with a grain of salt.

Back in the 3.12 & 4 days, every once-in-a-while a program would totally
screw up during development. Using the trace facility, I would watch as an
entire function or section of a function would execute with no reguard for
constraints, data flow or even logic. VEE would hop around, executing
objects seemingly at random.

The program would look fine on the screen, but obviously something in the
text file that constitutes a VEE program was making VEE wack-o.

I never did figure out exactly what the problem was because it was never
reliably reproducable. The solution, however, was to delete the affected
function or section of code, save the program, exit VEE, restart VEE, reload

the program and reconstruct what was deleted. It worked every time.

Looking back through my logs I see this hasn't happened since we started
using VEE 5. I certainly hope you can figure out what's going on in your
case.
-SHAWN-


-----Message d'origine-----
De: George Tyrrell [mailto:tdllc01@earthlink.net]
Date: 5 dcembre 2001 14:44

Thanks for the reply.

I do force firing of the input pin first with the sequence in/out.  That is
not left to chance.

Another piece of information I didn't add in the original message is that if
I use a To File or From File box without an input filename pin, and define
the path in the box, I still get the same error.

But that same user object will execute properly in a separate program, or on
a different platform.  Most puzzling.

George


-----Message d'origine-----
De: Shawn Fessenden [mailto:s_fessenden@hotmail.com]
Date: 5 dcembre 2001 14:29

>error 630, "Invalid Value".

Nine times out of ten, this is because the file object fires before the
filename input pin does. Constrain the from/to file objects by connecting
the sequence in to the sequence out of whatever object feeds the filename
input.
-SHAWN-


-----Message d'origine-----
De: George Tyrrell [mailto:tdllc01@earthlink.net]
Date: 5 dcembre 2001 13:10

I have encountered a problem with  File I/O on my customer's NT4.0 machine
running VEE 5.01.

The program I'm writing is an upgrade from a previous program which was
originally written in VEE 3.0 on HP-UX, running on an Envizex X-Terminal
with lan-GPIB gateways for instrument control.  This previous program was
then modified to run in the NT4 environment.  The upgrade program I'm
working on contains imported parts from the original, with new user objects
and user functions.  Compatiblity mode is set to "Standard". 

I use the file name control pin with the To File or From File Icon which
contains a known good path to the file, and encounter error 630, "Invalid
Value".  The error message which shows up indicates a file path as:
"C:Program FilesVee Programs     C:Program FilesDataFilesMyFile".   In
this example, the path "C:Program FilesDataFilesMyFile" is the correct
path to the file as entered into the File Name pin.  Probing the File Name
pin shows the correct path. 

This VEE program is contained in the path "C:Program FilesVee Programs",
and somehow VEE decided to use this as the first part of the file path,
which is definitely an invalid value.  Thus it is inserting the default path
in front of the actual desired path with several spaces between the two
paths, and attempting to use the combination as the file path.

A new program written on that same machine containing file I/O exactly as it
occurs in the upgraded program works correctly, no errors.  Importing the
user object from that new program into the upgraded program and executing
the upgraded program gives the error again.   The upgraded program I'm
writing works correctly on my development NT4 platform. 

Since a new program works correctly on the target platform, and the upgraded
program works correctly on the development platform, I am reluctant to take
the shotgun approach and re-install VEE or do any upgrades to NT4.
Something from the original program is causing the file path to be
incorrectly interpreted.

Any information about what causes the problem and how to correct it would be
greatly appreciated!

George Tyrrell
TestDynamics LLC
---------------------------------------------------------------------
This is the "vrf" maillist, managed by Majordomo.  To send messages to
this maillist, just email to "vrf@lvld.agilent.com".  Subscriptions and
unsubscriptions are done through the address "vrf-request@lvld.agilent.com".
If you need details, just send a message containing the text "help"
to "vrf-request@lvld.agilent.com".
---------------------------------------------------------------------

Outcomes