AnsweredAssumed Answered

vrf Execution does nothing ?!?

Question asked by VRFuser on Dec 7, 1999
I am having a mysterious problem with HPVEE today and I'm wondering if anyone
out there has seen anything like this and found the problem. I have all ready
polled my peers in my group with no results.

The problem is that one of my libraries has stopped operating as it used to on
arrays. It is a program to burn an EEPROM. All of the initialization stages
work, getting data values loaded, etc.  The problem comes up when it starts
putting the data into the array before the actual EEPROM burn.  The array gets
allocated and the line coming out of that contains 4096 0s as I would expect. 
However, each of the following blocks that fill the array just pass it on thru
without any effect except the array os Nil from the first set values block on.
The program does not crash until it gets to the first bit viewer (Y PLOT).

I checked for block execution and they all ran.
I checked the other data input pins and they all have data.
I ran it on a PC and found the error.
I ran it on a UNIX workstation and repeated the error.

The error is 400 = "Value is nil or empty (could be zero-element array)".

Simplified, it looks like this.

                     All 0s                   Nil          Error 400
                       |                       |               |
                       |                       |               V
  -----------------    V     --------------    V      ---------------------
| allocate array  |--------| set value    |---------| Y Plot (Bit Viewer) |
  -----------------          --------------           ---------------------

This is a mystery that I'm stuck on.
Can anyone help ?

This is the "vrf" maillist, managed by Majordomo.  To send messages to
this maillist, just email to "".  Subscriptions and
unsubscriptions are done through the address "".
If you need details, just send a message containing the text "help"
to "".