AnsweredAssumed Answered

8757E reset error

Question asked by VRFuser on Jun 1, 1998
Hello Gustaaf:
    
     I tested the 8757E standalone VEE driver again today on an instrument
     with firmware rev. 4.3 (latest and greatest), first with a National
     Instruments GPIB interface and then with an HP 82335B interface, and
     did not encounter any problems.  It is possible that this is a
     firmware issue.  I asked John Vallelunga about this, and he highly
     recommends an upgrade to firmware rev. 4.3 if Ruediger's 8757E does
     not already have it.
    
     Best Regards,
     Brad Hokkanen
     MID NA Support

______________________________ Reply Separator _________________________________
Subject: Re: 8757E reset error
Author:  RUUD KURK at HP-Netherlands,om3
Date:    5/29/98 5:28 AM


Hello Brad,
    
Below the reply from the customer.
Any idea what to do next?
    
Pls. reply to Gustaaf as I will be on vacation the next 4 wks.
    
best regards,
Ruud
---------------------------------------------------------------------
Hello Ruud,
    
I am sorry to answer so late. We use the source HP83751B and the
mm-WAVE-SOURCE-MODULE HP83558A to generate our mm-wave signal at W-band.
I have configured the 8757E analyser in VEE with the standalone driver
hp8757e.cid and first disconnect all other instruments form the
analyser. I send from VEE the reset command to the 8757E and the
analyser resets itself. Afterwards I got the error-message in VEE
    
   I/O-error or timeout occured with HP-IB inferface at 7
   Error number 811
    
I have set timeout to 30s and 60s. I got the error-message in both
cases.
    
Then I connected the source to the HP-IB and checked the reset again.
I got the same error message as before.
    
At least I connected the source to the system bus and checked again
the reset. Both instruments were preset and I got the error-message
as before.
    
Best regards and a happy weekend
    
  Ruediger
    
-------------------------------------------------
TU-Berlin
FG. Theoretische Elektrotechnik
Dip.-Ing. Ruediger Apel, Sekr. EN 2
Einsteinufer 17
10587 Berlin
    
Tel. +49 30 314 21418
Fax  +49 30 314 22284
email: apel@tetibm1.ee.tu-berlin.de
-------------------------------------------------   
    
    
    
    
    
______________________________ Reply Separator _________________________________
Subject: Re: 8757E reset error
Author:  BRAD HOKKANEN at HP-Sonoma,om2
Date:    28/04/98 19:53
    
    
     Hi Ruud and Stan:
    
     I talked to Greg Goebel at MXD a few minutes ago.  He found
     documentation indicating that these 8757 VEE drivers which communicate
     with the source thru the system bus have known problems unless the
     8757E firmware revision is 4.3 or higher (8757D firmware should be 6.2
     or higher).  He says there are no known problems when customers use the
     8757 standalone VEE driver with the VEE driver for their particular RF
     source and connect the source to the HPIB bus instead of the system
     bus.  Ruud, would you please ask your customer to try this and let me
     know if it works for him.  I can submit this to OSKR as an FAQ.
    
     Best Regards,
     Brad
    
______________________________ Reply Separator _________________________________
Subject: Re: 8757E reset error
Author:  rsb-at-sr (rsb@sr.hp.com) at HP-PaloAlto,mimegw2
Date:    4/28/98 9:27 AM
    
    
>      Hello Stan and Fred:
>     
>      It seems the VEE panel drivers that were written for the 8757 network
>      analyzers back in 1992/93 are now having a problem communicating with
>      whatever RF source is being used (with this analyzer, in passthru mode
>      on the system bus of course).  In reading the parts of the driver code
>      that aren't hidden (compiled), it appears that the HPIB addresses for
>      the analyzer (16), passthru (17) and source (19) are consistent
>      between the driver and the actual instruments.  The driver first
>      initializes the 8757 with no problem.  Viewing with my bus analyzer,
>      the driver is timing out (I set the driver timeout to 1 minute)
>      waiting for a response to the first command it sent to the source
>      ("OI" to query the instrument's ID).  I tested this first with my
>
    
Hi Brad
    
Might be able to diagnose this remotely, if you don't mind an
experiment.
    
Use DIO to query the instruments (OI) and let me know what string
is actually sent back. It appears that both instruments are
queried, so please do both.
    
If it works fine with DIO then there's no reaosn why we can't
make it work with the ITG driver.
    
Stan
    
______________________________ Reply Separator _________________________________
Subject: re: 8757E reset error
Author:  BRAD HOKKANEN at HP-Sonoma,om2
Date:    24/04/98 22:52
    
    
     Hello Ruud:
    
     We are encountering the same problem you describe.  We used an HPIB
     bus analyzer, and the problem is that the VEE driver is sending the
     "OI" (query of instrument ID string) command to the source via
     passthru, but the driver is having problems reading the string back
     from the source.  Since I believe the driver was written by the MXD
     division, and John and I aren't able to interpret the driver source
     code, I have to admit I don't know what to suggest.
    
     Best Regards,
     Brad Hokkanen
     MID NA Support
    
______________________________ Reply Separator _________________________________
Subject: re: 8757E reset error
Author:  RUUD KURK at HP-Netherlands,om3
Date:    4/24/98 8:49 AM
    
    
Hello Brad,
    
You ask:    
     Could you please let us know which of the following VEE drivers the
     customer is using?
    
     HP 8757E Scalar Network Analyzer (Standalone) (10/30/92)
        Files:  hp8757e.id / hp8757e.ih
     HP 8757E Scalar Network Analyzer (with HP834X Source) (08/17/93)
        Files:  hp8757e4.id / hp8757e4.ih
     HP 8757E Scalar Network Analyzer (with HP8350 Source) (08/17/93)
        Files:  hp8757e5.id / hp8757e5.ih
     HP 8757E Scalar Network Analyzer (with HP836X0 Source) (08/17/93)
        Files:  hp8757e6.id / hp8757e6.ih
    
     Best Regards,
     Brad Hokkanen
     MID NA Support
    
---------------------------------------------------------------------
    
Customer tried them all?
    
Any suggestion?
    
regards,
Ruud
______________________________ Forward Header __________________________________
Subject: re: 8757E reset error
Author:  Non-HP-apel (apel@tetibm1.ee.tu-berlin.de) at HP-Netherlands,mimegw3
Date:    4/24/98 4:39 PM
    
    
Hello Mr. Kurk,
    
I used the VEE driver hp8757e4.cid. In the help-file for this driver I
have read that the highest REV. is 4.2 and that is not the REV. no. of
our analyser. The other help-files do not contain any information about
the REV. no. .
I configured our analyser also with the other three drivers and I have
the same problem.
    
Best regards
    
Ruediger Apel
    
    
-------------------------------------------------
TU-Berlin
FG. Theoretische Elektrotechnik
Dip.-Ing. Ruediger Apel, Sekr. EN 2
Einsteinufer 17
10587 Berlin
    
Tel. +49 30 314 21418
Fax  +49 30 314 22284
email: apel@tetibm1.ee.tu-berlin.de
-------------------------------------------------
    
    


Outcomes