AnsweredAssumed Answered

Error 801 (serial port)

Question asked by VRFuser on Aug 18, 1999
Barrie,
Do you have a com port 23? I tried the DAV on serial 9 because for some
reason it's listed, but I only have 2 serial ports. I got exactly the same
message you did. I suspect if you do an I/O config from the H-P IO Libraries
(not in the VEE program) you won't see a serial 23. Even though you call it
23 The IO config will tell you if it finds one there. As for the unavailable
port in other applications I've seen that too. I thought doing an execute
close would do the trick, and it usually does, but unless the program is
somehow skipping that once in a while, I still get a more or less random
unavailable problem. Right now we use the com ports for three different
things: 1) communication with the UUT, 2) Controlling a Thor A.C. motor
speed controller, 3) Controlling an automatic syringe pump for barometeric
tests. Each device has a different protocol and I'm suprised it works.
Period. I'm really thinking about experimenting with the possablity of an
activeX component to take over the serial business.

-Andrew Kronquist


----- Original Message -----
From: Barrie Walden <bwalden@whoi.edu>
To: HPVee <hpvxd_xc@hpislsup.lvld.hp.com>
Sent: Wednesday, August 18, 1999 1:01 PM
Subject: Error 801 (serial port)


> Hi folks,
>
> I'm still wading through HPVee serial port issues.  My latest code
> provides the following error message:
>
> Configuration error: Serial interface @ 23 not active
> Refer to the Installation Manual
> Object title DAV: serial 23
> In UserFunction Direct_23
> Error number 801
>
> This occurs after the code appears to successfully use a Direct I/O
> object to read all characters in the port's buffer (terminated by a
> timeout).  Before running the offending code the port works correctly
> with Hyperterminal but the port is "not available" after running the
> code unless I exit HPVee completely.  I am using version 5.01 under NT.
>
> Any thoughts?
>
> Barrie


Outcomes