AnsweredAssumed Answered

PNA-X N5247A Error 103

Question asked by DHealy on Oct 22, 2019
Latest reply on Nov 7, 2019 by DHealy

Hi,

I have a VEE routine for capturing S-Parameters, which works when saving data on the E5080A ENA, but when I use it on the N5247A PNA-X, I get an error. The error number on the PNA-X is 103 and the message is “CALC measurement selection set to none”. Can someone explain what this means? The PNA-X firmware is Z.10.63.25.

The programming command for this from the VNA help file (Rev A.12.60 , 17-Jul-2018) for the E5080A has the following format:

CALCulate<cnum>:MEASure<mnum>:DATA:SNP:PORTs:SAVE <"x,y,z">,<filename>

I use the following command on the E5080A ENA which works. It takes in parameters for the measurement port numbers, directory path and file name.

"CALCulate:MEASure:DATA:SNP:PORTs:Save \'"+SnP_type+"\',\'"+Directory+"\\"+FileName+"\'"

 

The programming command from the PNA help file (Rev A.10.65.xx, 5-Mar-2019) for the PNA-X has the following format:

CALCulate<cnum>:DATA:SNP:PORTs:SAVE <"x,y,z">,<"filename">

It is basically the same as the command used on the E5080A except that :MEASure has been removed.

When I use the following command on the PNA-X, it does not work and I get the 103 error on the PNA-X. It takes in parameters for the measurement port numbers, directory path and file name.

"CALCulate:DATA:SNP:PORTs:Save \'"+SnP_type+"\',\'"+Directory+"\\"+FileName+"\'"

 

However, if I use the command below on the PNA-X, the S-Parameter file is saved. I would prefer to be able to set the port numbers

":MMEM:STOR \""+Directory+"\\"+FileName+"\""

 

Does anyone have an idea what the issue could be with the first PNA-X command and why it does not work?

 

Thanks,

Declan

Outcomes